What's new

Suddenly, I can't SSH any more

yoxi

New Member
Joined
Jul 2, 2011
Messages
4
Reaction score
0
iPhone 4, iOS 4.3.1 (and then 4.3.3) and OSX 10.6.8.

A couple of weeks ago, while I was still at 4.3.1, SSH suddenly stopped working. I just get port 22 timeouts when trying to get in via Terminal or Transmit or Cyberduck.

I tried reinstalling OpenSSH (and unchecking/rechecking the SBS toggle), but nothing has brought connectivity back. I then tried updating to iOS 4.3.3 in case that helped, but no dice.

Anyone else have this problem, and how have you solved it?
 
OP
Y

yoxi

New Member
Joined
Jul 2, 2011
Messages
4
Reaction score
0
First thing I checked :). I've tried setting it to default to specific addresses, as well as DHCP, but neither way will connect any more using SSH. Frustrating as hell.

Probably my next step should be disabling substrates to see if any recent update of something killed it by accident without me noticing.
 
OP
Y

yoxi

New Member
Joined
Jul 2, 2011
Messages
4
Reaction score
0
Nope, turned off all 3rd party substrates and still couldn't ssh in there. I'll have to keep hunting.
 

f4780y

Super Moderator
Staff member
Joined
Apr 11, 2011
Messages
916
Reaction score
153
Location
Troon, Scotland
I've often found this to be the wireless router. Have you tried power cycling it?
 
OP
Y

yoxi

New Member
Joined
Jul 2, 2011
Messages
4
Reaction score
0
Turns out the culprit was the router/modem that came with my broadband package. I've replaced it with a Netgear one that I already had around, and now my ssh is back to normal - and as a side effect, my broadband is faster, and I can access wifi from the other end of the house :).

I don't know what it was about the other router/modem that screwed things up, as it was working to begin with - the only difference I'm aware of is between ip addresses, the one that didn't work used the range 198.162.1.x and the Netgear one uses 198.162.0.x. Quien sabe.
 

Most reactions

Top