Mobile Rings Whilst on Do Not Disturb

Discussion in 'iPhone 5s' started by HunnieBunnie, Jun 19, 2019.

  1. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    I always put my phone on do not disturb (the little moon symbol) before going to bed at night and before lying down for a nap in the afternoon. Today, despite it being on do not disturb, two phone calls rang in within half an hour of one another.

    After the first call rang in, I checked to be sure it was set to do not disturb, and it was so set. So, I turned off the mobile and turned it on again. It was still set on do not disturb. A few minutes later, another phone call rang in. I was so annoyed because I was unable to fall back asleep. I did not recognise either of the numbers if that is significant at all.

    Anyone have any idea why this is happening? What do I do to correct it?? Never had this problem before since I have owned this mobile.

    Thanks!
     
  2. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    P.S. I just belled my 5s from another phone. The 5s was still on do not disturb, but the phone rang anyway. I guess until I can figure out why this is happening, I will have to turn my phone completely off before going to bed. :(
     
  3. scifan57

    scifan57 Super Moderator Staff Member

    Joined:
    Sep 24, 2012
    Messages:
    21,749
    Likes Received:
    18,657
    Trophy Points:
    113
    Location:
    Regina, Canada
    When selecting Do Not Disturb, have you selected Always under Silence? Also, is the Repeated Calls switch on? If it is a second call from the same person within three minutes will not be silenced.
     
    • Like Like x 1
  4. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    Hi scifan57. I do not see anything that says "Always under Silence." I just see a little moon shape. I always used to just touch the moon shape to put it on Do Not Disturb or to take it off of Do Not Disturb. It is just a little icon you can see if you brush up the screen from the bottom. I do not know anything about a "Repeated Calls" switch. Never heard of that before. The two calls came from two different numbers more than 3 minutes apart (I think). I did not specifically time it.

    I like to be able to check my phone during the night if I awaken, but I will turn it off completely if this is going to happen. I have a difficult time getting to sleep as it is. If I am awakened, it is really difficult to go back to sleep. My phone never did this before--ever. I can only surmise this has something to do with one the OS updates(?).
     
  5. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    Okay, I just found the Silence section in settings. "While iPhone is Locked" was checked. I checked "Always." Will this fix the problem??
     
  6. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    Well, I just tested. The settings says "Always." I put it on Do Not Disturb and belled myself from another number, and my 5s rang, so it is not fixed. :(
     
  7. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    I found the "Repeated Calls" thing and turned it off, and then I belled myself again, and the call still came through. This was quite awhile after the first try. I have no idea why it is doing this. In all the time I have owned this phone, it has never done this before.
     
  8. scifan57

    scifan57 Super Moderator Staff Member

    Joined:
    Sep 24, 2012
    Messages:
    21,749
    Likes Received:
    18,657
    Trophy Points:
    113
    Location:
    Regina, Canada
    What do your settings say in the Allow Calls From section of Do Not Disturb? Try setting it to No One.
     
    • Like Like x 2
    • Useful Useful x 1
  9. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    Tried it, and it worked! Thank you! What I do not understand is why anything changed, why any of my old settings changed, unless it had something to do with an OS update. What a relief, though, not to have to power down my phone just to be able to rest undisturbed. Thank you scifan57!.

    Now, can anyone tell me why after I turn off the Bluetooth icon, it turns itself back on the next day? My battery keeps running down even though the phone is not being using. Then, I noticed the Bluetooth icon was on. I do not use any Bluetooth products (not even sure what they are). I turn it off, and the next day it is on again. How do I make it stay off?
     
    • Like Like x 2
  10. carolineM

    carolineM Well-Known Member

    Joined:
    Sep 20, 2015
    Messages:
    1,164
    Likes Received:
    962
    Trophy Points:
    113
    You need to turn BlueTooth off under the main Settings for it to stay off.
     
    • Agree Agree x 1
    • Useful Useful x 1
  11. HunnieBunnie

    HunnieBunnie Active Member

    Joined:
    Sep 7, 2014
    Messages:
    339
    Likes Received:
    134
    Trophy Points:
    43
    ^^^ Thank you, I will try it!
     
  12. carolineM

    carolineM Well-Known Member

    Joined:
    Sep 20, 2015
    Messages:
    1,164
    Likes Received:
    962
    Trophy Points:
    113
    You’re welcome!
     
  13. scifan57

    scifan57 Super Moderator Staff Member

    Joined:
    Sep 24, 2012
    Messages:
    21,749
    Likes Received:
    18,657
    Trophy Points:
    113
    Location:
    Regina, Canada
    You're welcome, I'm glad I could help.
     

Share This Page