What's new

Heres my method of downgrading ios from 5.1 to x.x on A4 devices.

davegurn

New Member
Joined
Feb 28, 2012
Messages
54
Reaction score
0
I posted this in another thread and thought it might help in its own thread if people use the forum search. you can downgrade to many of the older ios versions aslong as you have the shsh blobs for that ios version and create a custom ipsw with its shsh blobs attached. I have used 5.0.1 as the ios i want to downgrade to in this turtoral so just switch it to whichever you want to downgrade to. This should also work for downgrading older ios versions ie 5.0.1 to x.x and so on.

Note, this tutorial will not work with apple A5 devices Iphone 4s and Ipad 2! If you have upgraded your apple A5 devcice Iphone 4s or Ipad 2 to ios 5.1 it is irreversible and currently an A5 device can only be restored to the latest ios. This tutorial will work with apple A4 devices iPhone 4, 3GS, iPad 1 and the ipod touch.

1) First of all you need the shsh blobs for 5.0.1 or the ios version you want to downgrade to, (shsh blobs are what apple sign there ios ipsw's with to verify them and itunes usally contacts apple to gather these and verify your install but once a new ios is released apple stop signing the previous ios versions and so when itunes contacts apple it cannot find them so it does not allow you to install, so what you need to do is create an ipsw that already has the shsh blobs attached to it so itunes doesn't need to contact apple.

2) to get your shsh blobs follow this members tutorial (Thanks f4780y) and you should see an shsh blob for 5.0.1, but if tinyumberella does not find the shsh blob for the ios version you want to downgrade to you will have to find them elsewhere but im not going to cover that here. The rest of this tutorial assumes you have the shsh blobs for the ios version you want to restore/downgrade to.

3) Download the official apple 5.0.1 ipsw or the official ipsw for the ios version you want, you can get the official ipsw's for your device type from here and make sure you remember where you saved it.

4) Now download redsn0w from here for mac and from here for windows

5) Now open redsn0w and go to extra>shsh blobs>stich and this is where you will create your custom ipsw with the shsh blobs attached to it. Click "ipsw" and select the 5.0.1 ipsw or the ipsw for the ios you selected and downloaded earlier, and then click "local" and select the 5.0.1 shsh blob
you found with tiny umberrala earlier or the shsh blob for the ios version you selected, if you don't know where your shsh blobs folder is open tinyumberrella and click advanced and it tells you what directory your shsh blobs are saved to. And then let it do its thing and once its finished it will tell you your ipsw was created and will put it in the same folder as the original ipsw with a bunch of numbers before it.

6) Now you need to get your device into "Dfu Mode" and then "Pwned Dfu mode", you alway need to get your device into "Pwned Dfu Mode" to enable itunes to downgrade/restore to a custom ipsw, itunes won't allow you to restore to the ipsw you've created earlier without your device being in "Pwned Dfu Mode" and you can't enter "Pwned Dfu Mode" without first putting your device into "Dfu Mode"
(heres a thread about "dfu mode" thanks f4780y), luckily redsn0w guides you through how to do this so first make sure your device is plugged into the computer via usb, and then open "redsn0w" and go to extras>pwned dfu and follow the instructions redsn0w gives you to get into "dfu mode". (note "dfu mode"is not the same as "pwned dfu mode" but you need to get into "dfu mode" first to allow "redsn0w" to put your device into "pwned dfu mode". If you follow "redsn0ws" instruction correctly "redsn0w" should tell you your device is now in "pwned dfu mode" and ready for itunes to restore with a custom ipsw. (If it errors on the timers to get into dfu mode go back and start again) remember unless "redsn0w" confirms your device is in "Pwned Dfu Mode" you have done something wrong so restart the "redsn0w" "pwned dfu" steps.

7) Now open itunes (it should say your device is in recovery mode) and click your iphone and then (shift + left click "restore" for windows) or (alt + left click "restore" for mac) and a file browsing window should pop up, and now you browse to your custom ipsw with the bunch of numbers before it that you created with redsn0w earlier and select that. and if you have done everything correctly itunes should now restore your device to 5.0.1 or the ios version your trying to downgrade to.

8) You should now have a factory default 5.0.1 ios device or whatever ios you selected. Now to jailbreak simply plug your device in via usb, open "redsn0w", click jailbreak, follow the instruction, select install cydia and now your jailbroken again :). Or use your own prefered jailbreak method.

I have used these steps multiple times without a problem so if it doesn't work you've done something wrong, hope this helps you downgrade/restore your device :)


And if any senior members notice something i've missed i will be happy to hear and correct it.
 
Last edited:

Hungryghost

New Member
Joined
Jul 20, 2011
Messages
120
Reaction score
2
Hi, quick question, whenever I try this redsnow tells me "memory exhausted". My laptop is old and only has 512mb. I guess this is the reason? Is there any way round this? I have been able to make an iFaith custom firmware but I would like a redsnow one just in case.
 
OP
D

davegurn

New Member
Joined
Feb 28, 2012
Messages
54
Reaction score
0
Not sure, definatly a problem specific to your laptop.

But i would of thought even 512 was enough for redsn0w, maybe redsn0w is a ram guzzler.
 
Last edited:

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
Hi, quick question, whenever I try this redsnow tells me "memory exhausted". My laptop is old and only has 512mb. I guess this is the reason? Is there any way round this? I have been able to make an iFaith custom firmware but I would like a redsnow one just in case.

Use iFaith with Tiny Umbrella blobs. So much more efficient. Redsn0w's stitching process still is not perfected. iFaith,......that sh** is perfected.lol
 
OP
D

davegurn

New Member
Joined
Feb 28, 2012
Messages
54
Reaction score
0
From a few of your post's it seems i love redsn0w for custom restoring and you love ifaith lol, i suppose its cos i used redsn0w first and i haven't had any problems with it so you just go with what you know. at the end of the day they both do the exact same thing.

but to each his own :)
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
davegurn said:
From a few of your post's it seems i love redsn0w for custom restoring and you love ifaith lol, i suppose its cos i used redsn0w first and i haven't had any problems with it so you just go with what you know. at the end of the day they both do the exact same thing.

but to each his own :)

Maybe I only had problems cuz I used old blobs with a 5.0 ipsw. Which I had to tweak system files to make redsn0w recognize the APTicket. Maybe that's why. I'll give a try next time.lol.
 
Last edited:
OP
D

davegurn

New Member
Joined
Feb 28, 2012
Messages
54
Reaction score
0
yeah fair enough, if i start experiencing problems with redsn0w iyl give ifaith a try. i like redsn0w as an all in one tool though.
 

mongo549

New Member
Joined
Mar 21, 2012
Messages
11
Reaction score
0
I have another post out there but it's not getting further replies. I want to upgrade to IOS 5.0.1 from 4.2.1 on an iPhone 4. I can't get redsn0w to stich my SHSH blobs saved with Tiny umbrella. It will not even let me select local when I go into Extra>Stich, it's greyed out. Will Ifaith work for this? I've started having some performance issues and hope upgrading to 5.0.1 will resolve. I am running the latest version of iTunes although I have not had a chance to get that far yet. Any suggestions? Is there anything obvious I'm doing wrong? I'm using redsn0w_win_0.9.10b4. Any assistance would be greatly appreciated.
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
mongo549 said:
I have another post out there but it's not getting further replies. I want to upgrade to IOS 5.0.1 from 4.2.1 on an iPhone 4. I can't get redsn0w to stich my SHSH blobs saved with Tiny umbrella. It will not even let me select local when I go into Extra>Stich, it's greyed out. Will Ifaith work for this? I've started having some performance issues and hope upgrading to 5.0.1 will resolve. I am running the latest version of iTunes although I have not had a chance to get that far yet. Any suggestions? Is there anything obvious I'm doing wrong? I'm using redsn0w_win_0.9.10b4. Any assistance would be greatly appreciated.

You need redsn0w 0.9.10b6.

ALWSY upgrade to the latest redsn0w.

Second. Make sure you very your 5.0.1 blobs with redsn0w to verify the APTicket is present and valid.

Third: iFaith does this much better then redsn0w.

Just choose the 5.0.1 SHSH blob from Tiny Umbrella and turn choose the 5.0.1 IPSW.

Tho I think the blobs stitching bugs were fixed in the latest redsn0w (0.9.10b6).
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
bradybunsh said:
You need to restore and update your iPhone 4 that Is what I did.

Of coarse that will work. That's not hat hes trying to do.

He's trying to use his SHSH blobs for 5.0.1.

He does not have give up and update to 5.1. He can use his blobs to restore to 5.0.1 (provided he has full 5.0.1 blobs)...and I told him how to do it.
 

mongo549

New Member
Joined
Mar 21, 2012
Messages
11
Reaction score
0
Thanks guys I'll try downloading iFaith. I did upgrade to the latest redsn0w (b6) and verify the shsh, 5.0.1 did verify and and the APTticket the strange thing is none of the 4. versions verified with the APTticket. I also tried manually selecting the IPSW and got a message the IPSW was not supported by this version of redsn0w. Should I try to redownload from the apple site? When I tried to stich redsn0w kept giving me the message 'unable to parse, are you sure this is an ipsw?'. I downloaded from the site on this board and changed the .zip to .ipsw. It created the the box and said it was apple firmware. Do I have something else wrong, I'm a little conserned that all my 4.X blobs said the APTticket was MISSING. Any further suggestions, should I hold off and wait for a untethered version of 5.1? Thanks for all your assistance.
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
iFaith also builds a self signed IPSW. It does not only dump blobs. iFaith has been used to dump blobs and build self signed IPSW's for whatever iOS you are currently on. And has been doi g it long before redsn0w.

Plus iFaith does not support 5.1 yet any way.

This is what iFaith does:

1) Extracts and saves blobs locally to your computer and saves them to the iH8sn0w server.

2) Buids a custom IPSW stiched with SHSH blobs.

3) Can use iFaith blobs (duh.lol) Tiny Umbrella Blobs, and redsn0w blobs.

4) can at any time download any available SHSH blobs.

5) Can also download the IPSW you need. (Tho I don't know where it saves it.lol. It downloads it, builds the signed IPSW, then that it.....The signed IPSW shows up on your desktop. Dont know what happens to the downloaded stock IPSW)

iFaith is my most favorite tool in the world.....next to redsn0w.lol.................Sn0wbreeze is okay I guess. Even better now that it can use SHSH blobs to build a signed pre-jailbroken IPSW;)
 
Last edited:

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
Sounds like you may have the wrong IPSW. IPSW's are specific to your device model.

Ya dont just download a 5.0.1 IPSW. You downoad an iPhone 4 CDMA or GSM (whichever you have) 5.0.1 IPSW. Not just any IPSW
 
Top