What's new

Unable to update 3GS to 5.1.1 from 4.3.2 - Details of my futile attempts inside!

schmake

New Member
Joined
Oct 27, 2012
Messages
7
Reaction score
0
Location
Queensland, Australia
I have been trying to update my iPhone 3GS from 4.3.2 to 5.1.1 with absolutely no luck. Here are my details:
  • iPhone 3GS 4.3.2, Baseband 05.16.02
  • Using redsn0w 0.9.15b2
  • Blobs: have blobs from 3.1.2 to 5.1.1
  • hosts: All apple references are commented out, gs.apple.com redirects to apple placeholder site
Here are some different methods I have tried (which I documented), and outcomes:

1.
Create custom ipsw (5.1.1), stitch my blobs (5.1.1) into it
Enter PwnedDFU mode
Open iTunes, attempt to restore the custom ipsw
"iPhone" could not be restored. An unknown error occurred (3194)

2.
iPhone on/normal
Open iTunes, attempt to restore the custom ipsw
"XXX iPhone" could not be restored. An unknown error occurred (3194)

3.
Using redsn0w 0.9.15b2
Extras -> Even More -> Restore
preserve baseband = Yes
place in Pwned DFU mode
Tried custom (stitched) ipsw - "Found none of the expected files to stich in IPSW: xxxxxxxxx"

4.
redsn0w 0.9.15b2
Extras -> Even More -> Restore
preserve baseband = No
place in Pwned DFU mode
Tried stock 5.1.1 ipsw - "Found Device in DFU mode instead of Recovery mode"


I am pulilng my hair out here, have I done something supremely silly or wrong? Any help to update this iPhone would be greatly appreciated.
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
Open up TinyUmbrella and untick 'Set Host to Cydia' under the Advanced tab. Then delete the host.umbrella file that should be with your host file. That fixes the 3194 in conjunction with the host gs.apple.com removal in the regular host. Make sure iTunes is closed out completely. Retry the first option after.
 
OP
schmake

schmake

New Member
Joined
Oct 27, 2012
Messages
7
Reaction score
0
Location
Queensland, Australia
Thanks mate tried your suggestions, but unfortunately the same response:
"The iPhone "iPhone" could not be restored. An unknown error occurred (3194)."

In TinyUmbrella 'Set Host to Cydia' options are disabled for me. Completely greyed out, but not ticked.
I deleted the hosts.umbrella file too.

I've got no idea what is going on here.....
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
In that case, close out iTunes, remove any and all gs.apple.com lines from your host file, then flush your DNS.

On Mac, open Terminal and run
dscacheutil -flushcace

On Windows, go to Start>Run>Cmd or Start>Cmd (search) and run
ipconfig /flushdns

Then try again
 
OP
schmake

schmake

New Member
Joined
Oct 27, 2012
Messages
7
Reaction score
0
Location
Queensland, Australia
I removed the already commented lines from the host file and flushed DNS, still no joy. For both 1 & 2 in first post: "The iPhone "iPhone" could not be restored. An unknown error occurred (3194)."

I also tried methods 1&2 from the first post on another couple of machines here, an old XP machine (which I just installed iTunes on tonight) and Windows server 2008R2 (iHomeServer machine), same result.

Any other ideas? I don't like my chances of going up to 6 and back seeing as I can't even get to 5.1.1 from a jailbroken device :(
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
Whether or not a device is jailbroken is irrelevant, since the jailbreaks through RedSn0w will put an entirely new iOS installation onto your iPhone. If you're still getting 3194, you'll need to tinker with TinyUmbrella until you can toggle the tick and untick for Set Host to Cydia, because if you're still getting the 3194 after removing host.umbrella and gs.apple.com, then it's a TinyUmbrella problem.
 
OP
schmake

schmake

New Member
Joined
Oct 27, 2012
Messages
7
Reaction score
0
Location
Queensland, Australia
Thanks for all your help mate, but I can't see how this is a TinyUmbrella/hosts problem. On the machine where I started all this, the url gs.apple.com goes to an apple placeholder.

I've tried on several machines
- 64bit Windows Server 2008R2: never used TinyUmbrella, redsn0w etc on it, pure AirPlay server machine. Same result
- Win XP SP3: fresh install of iTunes, never used TinyUmbrella, redsn0w etc on it. I even made it external to my network, 3G mobile connection (just ensure my network wasn't the issue). Same result
- Virtual Machine: I even built a fresh Win XP VM on my linux box, complete with fresh iTunes install. Same result

I'm at a loss. Tomorrow I can try at a completely different location, but I believe I've covered that with my tests above. It's after 2 in the morning here and spent waaaaay too long trying to get this work.

Once again, thanks for your help
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
Open up TinyUmbrella, Start TSS Server, then try again.
 
OP
schmake

schmake

New Member
Joined
Oct 27, 2012
Messages
7
Reaction score
0
Location
Queensland, Australia
Thought I'd start a new day with some more success.... unfortunately not :(

Started TSS server on TinyUmbrella
Put phone into PWnedDFU mode using redsn0w
Tried restoring custom ipsw using iTunes
Took a lot longer than usual, stuck at 'Preparing iPhone for Restore' for a while
Then "The iPhone "iPhone" could not be restored. An unknown error occurred (1602)"

I had my hosts file open in jEdit to review, although I can not tick/untick 'Set Host to Cydia', TinyUmbrella commented out any lines directing gs.apple.com to either local host or cydia after closing.

Any other ideas? Could I have created the custom ipsw incorrectly?
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
To 1600 error means that you're not in the correct DFU mode for the restore. You could've created a bad IPSW or a wrong one. Make sure you've downloaded the IPSW through a non-Internet explorer browser
 
OP
schmake

schmake

New Member
Joined
Oct 27, 2012
Messages
7
Reaction score
0
Location
Queensland, Australia
One final update:
I re-downloaded the following firmware (http://appldnld.apple.com/iOS5.1.1/041-4347.20120427.o2yov/iPhone2,1_5.1.1_9B206_Restore.ipsw) using Firefox, checked CRC with the one I had here, identical
I created another custom firmware using sn0wbreeze v2.9.6
I used redsn0w to put the iPhone into PwnedDFU mode each time and tried restoring with iTunes several time, got another 3194 and more 1602 errors.

Got jack of it not working, updated to iOS 6 then jailbroke
Only issue was that my backup from PkgBackup got corrupted somehow, so I had to manually restore all my cydia settings.

Didn't want to go to iOS 6, but will stick with it for a while as I'm not sure my phone will play nicely and downgrade....


Thanks for all your help :)
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
If not, try this, now that you're on iOS 6, downgrade back to iOS 5.1.1. I helped with another user do this using TeamViewer just a few days ago. It worked after a few hours but we got it working
 
Top