What's new

Unlocked cannot use data


New Member
Feb 2, 2012
Reaction score
I have a 3gs that is factory unlocked problem is I am using red pocket and i cannot set up data as directed because att locks that out I have read that jailbreacking it will allow me to manually set data up so can i jailbreak version is 6.1.6 (10B500) modem firmware 05.16.08.
You'll need to install SAMprefs and provide your phone with the proper APN settings. You can go to www.unlockit.co.nz, and look up Red Pocket's APN settings, them fill the appropriate fields out through SAMprefs from Cydia

Sent from my iPad using Tapa
ok thanks I have red pocket's APN just not sure i can jailbreak it and if so what jailbreak to use and can it be untethered. if i am correct it will be Redsn0w 0.9.15b3 and will i need this Step 2: Download iOS 6.0 firmware file (yes, the trick is to point Redsn0w to the iOS 6.0 firmware file and NOT iOS 6.1.6 firmware file) for your iOS device from the links mentioned below: thanks for your response. and will this be the correct file 6.1.6 (iPhone 3GS): iPhone2,1_6.1.6_10B500_Restore.ipsw
Last edited:
Yes. Because the Dev Team (@Evad3rs) has not updated RedSn0w to support 6.0.1-6.1.6, but the overall code in the iOS revolves around 6.0, you'll have to select the 6.0 IPSW. This tutorial shows you step-by-step how to do it
OK thank you very much for your response you have been very helpful. Now if I don't screw it all up maybe I can use what I pay for lol.
help lol I did as instructed went to cyndia installed P0sixspwn rebooted and now it just sets on apple logo and every three minutes looks like it reboots just keeps doing this over and over been 15 -20 minutes now. Did i kill the phone

Are you using the latest p0sixspwn?

Sent from my iPhone via Tapatalk Pro
i think so i searched for it in cyndia then install it said reboot well it wont I just tried booting it with redsn0w it went through the pineapple on screen now we are back to the apple logo and there it sets.
should i try forced DFU and restore in Itunes
tried but that did not work I tunes says unknown error occurred 3194
this is what i get for wanting to use what i pay for lol
updated itunes and tried again and it did restore it so any idea what went wrong only thing I did that i was not sure on was where it ask if it was a newer 3gs i said no because according to serial # it was made in week 28 is that correct to answer no? I used Redsn0w 0.9.153b and this Iphone2,1_6.0_10a403 restore ipsw. or was i supposed to use this ispw 6.1.6 (10B500) modem firmware 05.16.08.
Last edited:
under general on my phone at version says 6.1.6 (10B500) and modem firmware says 05.16.08.
I ran redsn0w again it completed phone is working and cydia is installed and working a little confused though i thought this would be tethered jailbreak untill i install p0sixspawn but cydia works every time i reboot the phone untethered. so now how do i install SAMprefs? i tried searching for it in cydia no luck. or am i that confused as to what SAMprefs is i thought it was so i can enter info that will allow me to use my red pocket data.
Last edited:
all this and all i have to do is go red pocket and install a app damn. i think data works the weather updated but safari says it could not connect to server.