What's new

No 3G connection after jailbreak

beakybeecroft

New Member
Joined
Aug 28, 2011
Messages
10
Reaction score
0
Well I finally got my 3GS jailbroken again but my 3G connection isn't working. The 3G symbol appears at the top of the screen but it won't actually connect me to web sites. When this happened before it resolved when Cydia asked me to do some essential updates so I clicked OK it chuntered for a while and then Cydia reloaded and my 3G worked- no idea why! This time Cydia isn't asking to do any updates:0(. Any ideas?
 
OP
B

beakybeecroft

New Member
Joined
Aug 28, 2011
Messages
10
Reaction score
0
Okay I re jailbroke using same method as before redsnow 0.9.8b5 and firmware 4.3.3 and this time it opened up the phone on completion without me doing a tethered boot! I have switched it on and off again and it boots up fine, no tether required which is good but unexpected! However, safari does not work, it just opens and immediately closes even though wifi and 3G are working fine, and Cydia does the same- just opens and immediately closes again. Any ideas on how to fix? I am not wanting Cydia as I never wanted a jailbroken phone (I bought one on eBay that was not listed as jailbroken and have been wrangling with it ever since!) but I do want Safari back!
 

iCrank

Member
Joined
Feb 27, 2011
Messages
5,590
Reaction score
88
Location
Vallejo, Ca
beakybeecroft said:
Okay I re jailbroke using same method as before redsnow 0.9.8b5 and firmware 4.3.3 and this time it opened up the phone on completion without me doing a tethered boot! I have switched it on and off again and it boots up fine, no tether required which is good but unexpected! However, safari does not work, it just opens and immediately closes even though wifi and 3G are working fine, and Cydia does the same- just opens and immediately closes again. Any ideas on how to fix? I am not wanting Cydia as I never wanted a jailbroken phone (I bought one on eBay that was not listed as jailbroken and have been wrangling with it ever since!) but I do want Safari back!

I don't get it...you restored a jailbroken iPhone just to renal break it and now claiming you don't want it....hmmm btw you performed a untethered jailbreak...try (hold sleep/wake and home buttons until you see apple logo and release) hopes this fixes the safari, Cydia issue..bc if it doesn't are you ready to restore again
 

bab2010

Well-Known Member
Joined
Feb 6, 2011
Messages
7,009
Reaction score
65
Location
Beijing
I remember I was able "seems like" to untether jailbreak my iPhone 4 back to the time when untether for iOS 4.3.1 I think wasn't release yet. Those time I used snowbreeze to want to untether jailbreak my iPhone and I was having the exact same situation with my safari and cydia after the jailbreak. In fact it wasn't jailbreaked, and the ios got corrupted too, and that was why I was able reboot, and safari was crashing because of corrupted files. I think that the exploit use by those jailbreak tools are in safari, so when the jailbreak fail but finish the process safari will crash cydia was never fully installed during the jailbreak and so it crash as well. I could confirm that the jailbreak fail when I try to access root files on my phone using discaid and it wasn't possible.
Basically, there is nothing that you can do to fix safari and cydia, but if you are sure that you are on iOS 4.3.3, an if you can use iTunes to factory restore that iOS 4.3.3 then do that, and after, go to jailbreakme.com to jailbreak your phone.
 
Last edited:
OP
B

beakybeecroft

New Member
Joined
Aug 28, 2011
Messages
10
Reaction score
0
Okay just to clarify the phone says it is running 4.3.5 hence my surprise at the untethered jailbreak ( or so it seemed). I hav only done the jailbreaking to try and ge the phone working as I didn't know it was jailbroken when I bought it as the listing didn't mention it and I had never heard of Cydia so it didn't raise alarm bells when I fist switched the phone on. When I first connected it to my computer it asked me to upgrade to 4.3.5 so I clicked okay and after it attempted to install the update it went into recovery mode and gave a 1015 error. I managed to rejail break it on the advice of a friend who has a jailbroken phone using redsnow and 4.1 ( as this is the iOS it would have been shipped with after manufacture according to info gleaned from the serial number) and it worked but was tethered. I then followed advice online that I could now do a factory restore and update to update and unjailbreak my phone this time it did he same recovery loop and 1015 error and a reattempt with dfu mode and option/restore didn't work either. Eventually I managed to rejail break it and the prob with the 3G began. That's when I rejailbroke why fixed the 3G but started the prob with safari and Cydia. Not bothered about Cydia but would like safari back. Any process that involves a restore only leads mento a 1015 error so not an option ( have tried ireb fixrecovery irecovery to no avail). So that's my loooooooong story of a reluctant jailbreaker!
 
Top