What's new

Jailbroken phone won't run apps


New Member
Jun 22, 2014
Reaction score
I have a jailbroken phone (or so it seems) running iOS 5.1.1 and Cydia 1.1.12. I hadn't used in a few months, and when I turned it on, it said I needed to update some critical packages, and I selected to upgrade all.
Now, when I try and run applications, I get:
Killed: 9 on the terminal
dmesg says: AMFI: hook..execve() killing pid 339: no code signature

I tried rejailbreaking it, but absynthe won't let me.

Any suggestions?
It's always best to perform Cydia upgrades in small batches to zone out the issue if one comes up, particularly when you perform critical updates which includes but is not limited to Cydia Installer, Cydia Substrate and APT libraries, all of which received pretty significant overhauls in the past month due to Cydia being upgraded to break the 65535 package limit and to boost Cydia performance. I'd recommend performing a backup of your device, restore it, and rejailbreak the device assuming we're referring to an iPhone 3GS or iPhone 4.

Alternatively, I'd recommend running MobileTerminal from Cydia, and running the following commands in succession and reboot/respring (rebooting is always recommended when dealing with Cydia changes that do not include the updating of non-Cydia packages)

1. su
2. alpine
3. apt-get remove Cydia
4. apt-get install Cydia
Thanks for the quick response. Unfortunately it did not work. I installed apt-get. Removed the package. Reinstalled. I still get the killed response. I don't have a backup of the old iOS. I can either fix this phone or upgrade to iOS 7.1.1.
Last edited:
If it's an iPhone 4 you can tethered jailbreak it with GeekSn0w. If it's a 4S, you'll have to wait a bit for the 7.1.X or 8.0 jailbreak. Outside of that, I don't think there's a non-restore-related solution AFAIK unfortunately

Sent from my iPad using Tapa