What's new

iMessage Display Name

ispperformance

New Member
Joined
Nov 14, 2011
Messages
1
Reaction score
0
Ok, so I have been texting many of my fellow iphone owners, and today one of them says who is this? What? I guess on their end it only shows up as my gmail email address. My wife got her new iPhone today, and I sent a text message to her, and sure enough it shows up as my gmail email address. When I sent a message from her phone it shows up as her name. I have checked everything I can think of, and have not been able to find much on the forum or searching the web. All I have recently done was upgrade from 3GS to 4S. If anyone has any ideas on how to fix this please let me know, it's making my friends crazy now.
 

dannyboyg

New Member
Joined
Nov 16, 2011
Messages
1
Reaction score
0
iCrank said:
You have to set the caller id. You have it set to your apple id. You can change that in settings>messages>receive at>caller id.

What is the different outcome between setting caller ID to my iPhone number or Apple ID?
 

iCrank

Member
Joined
Feb 27, 2011
Messages
5,590
Reaction score
88
Location
Vallejo, Ca
dannyboyg said:
What is the different outcome between setting caller ID to my iPhone number or Apple ID?

The only outcome is how the receiver receives your SMS. If you select your apple id it will pop up on their phone as a email
 

chris50smith

New Member
Joined
Nov 20, 2011
Messages
2
Reaction score
0
The only outcome is how the receiver receives your SMS. If you select your apple id it will pop up on their phone as a email

I have the exact same problem. When I go into >setting>messages>Receive At> It does have my "Apple Id" selected, but does not allow me make any other selections.
If I click on the "Apple ID" section it only give my email address as an option.

Below it says "You can be reached for messages at:" then it shows my phone number, which is grayed an not selectable, and then below that it shows my email address as well.

Below that is says 'Caller ID", when I click on Caller ID it give me the option to select my phone number OR my email address. My phone number is selected.

I am stumped!! Help! Thanks!
 

ironman3503

New Member
Joined
Oct 21, 2011
Messages
3
Reaction score
0
I'm having the exact same issue! What is going on? If I turn off email and send as regular text then my name comes up for friends to see.
 
Last edited:

thewitt

Member
Joined
Oct 5, 2011
Messages
402
Reaction score
16
You show up to them as what's in THEIR address book.

If you set your caller I'd as your phone, then whatever their entry for your phone number says is what they see. Same for your email address.

If you have a phone and iPad and want messages to be read on both, you need to set your caller I'd on both to your email address.
 

ironman3503

New Member
Joined
Oct 21, 2011
Messages
3
Reaction score
0
If I send regular text I show up as what's in their address book if I send iMessage it shows up as my email address.
 

chris50smith

New Member
Joined
Nov 20, 2011
Messages
2
Reaction score
0
ironman3503 said:
If I send regular text I show up as what's in their address book if I send iMessage it shows up as my email address.

Yes. Mine is the same. It is only affected when using iMessage. I do not want to turn iMessage off, but may have too. Any other thoughts? Next might be a visit to the Apple store. (or should I call apple support?)
 

ironman3503

New Member
Joined
Oct 21, 2011
Messages
3
Reaction score
0
chris50smith said:
Yes. Mine is the same. It is only affected when using iMessage. I do not want to turn iMessage off, but may have too. Any other thoughts? Next might be a visit to the Apple store. (or should I call apple support?)

If I send regular message and they reply I don't receive it ugh
 

Ailment

New Member
Joined
Nov 27, 2011
Messages
1
Reaction score
0
Ok, so I have been texting many of my fellow iphone owners, and today one of them says who is this? What? I guess on their end it only shows up as my gmail email address. My wife got her new iPhone today, and I sent a text message to her, and sure enough it shows up as my gmail email address. When I sent a message from her phone it shows up as her name. I have checked everything I can think of, and have not been able to find much on the forum or searching the web. All I have recently done was upgrade from 3GS to 4S. If anyone has any ideas on how to fix this please let me know, it's making my friends crazy now.



Settings messages sign out of apple ID leaving only phone number as receiving entry. Fixed
 

Soarer

New Member
Joined
Jan 12, 2012
Messages
2
Reaction score
0
Settings messages sign out of apple ID leaving only phone number as receiving entry. Fixed

Ailment, THANK YOU!!! I spent a half hour on the phone with apple tech support and they couldn't figure this out. You nailed it. I just signed out of my apple ID like you described and people are now receiving my iMessages as they should, with my name not email. Thanks!!!
 
Top