What's new

Power Button Problems

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
I have the Iphone 4 from Verizon. Starting last night when I press the power button at the top of the phone

it reboots me into safe mode. It does this everytime. Any suggestions why or how I can fix this problem? I have

tried rebooting, I have tried doing a hard reset holding the power button and the home button and nothing has

worked.

Thanks
 
Last edited:

Skull One

Super Moderator
Staff member
Joined
Apr 27, 2011
Messages
4,431
Reaction score
580
Location
Earth
Try doing a full backup and then a full restore.
 
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
Try doing a full backup and then a full restore.

I'm jailbroken, on 5.0.1 and I dont want to lose that. Has no one else had this problem.

When Im on the lock screen I can push the power button and it closes like it should. But

any other time when I push the power button springboard crashes and boots me up in safe mode.

Any suggestions?

Thanks
 

Mickey330

Administrator
Staff member
Joined
Aug 12, 2011
Messages
1,845
Reaction score
363
Location
western NY state (USA)
Do you have Activator installed? Maybe you've somehow activated the Sleep button to go into Safe Mode when pressed - via Activator?

Or, think back to before this problem occurred. Have you recently installed any Cydia tweaks? You might have one that's interfering with the iPhone (or with another tweak). If this behavior just started, it may be due to that. Just remove any recently installed tweaks (paying close attention to Mobile Substrate-using tweaks) and see if that helps.

Other than that, I've got nothing, sorry.

Marilyn
 
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
Do you have Activator installed? Maybe you've somehow activated the Sleep button to go into Safe Mode when pressed - via Activator?

Or, think back to before this problem occurred. Have you recently installed any Cydia tweaks? You might have one that's interfering with the iPhone (or with another tweak). If this behavior just started, it may be due to that. Just remove any recently installed tweaks (paying close attention to Mobile Substrate-using tweaks) and see if that helps.

Other than that, I've got nothing, sorry.

Marilyn

I uninstalled Activator and reinstalled it and that did not work. Then I went into Cydia and uninstalled any recent downloads and still nothing. This is getting pretty annoying.

Thanks for the help
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
I uninstalled Activator and reinstalled it and that did not work. Then I went into Cydia and uninstalled any recent downloads and still nothing. This is getting pretty annoying.

Thanks for the help

Uninstalling and reinstalling Activator would not change anything. The settings would still be the same after installing again.

Does this happen when you press the sleep button on the lock screen? SpringBoard? Or both?
 
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
Uninstalling and reinstalling Activator would not change anything. The settings would still be the same after installing again.

Does this happen when you press the sleep button on the lock screen? SpringBoard? Or both?

It only happens when i press the sleep button on the SpringBoard.
 

Thomasjtsi

Well-Known Member
Joined
Oct 25, 2011
Messages
7,523
Reaction score
451
Location
Missouri, USA
Ok.. have you checked your Activator settings to see if you have it set to go into Safe Mode when performing a Short Hold of your power button?
 
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
I looked at Activator and checked the home button, short hold unassigned, short assigned unassigned. The sleep button double press and short hold are also unassigned. So the best i can tell nothing should be assigned to this.
 
Last edited:
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
I even went into Activator and reset settings hoping this would work, but still nothing.
 

OJsakila

New Member
Joined
Jun 21, 2011
Messages
159
Reaction score
0
Location
Savannah, GA
How about uninstalling a bunch of those cydia tweaks AND THEN TRY THE HOME BUTTON. Slowly reinstall one by one until you find the problem..
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
OJsakila said:
How about uninstalling a bunch of those cydia tweaks AND THEN TRY THE HOME BUTTON. Slowly reinstall one by one until you find the problem..

This may work....
 
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
I uninstalled Activator which uninstalled SBsettings and still nothing. What is the best was to uninstall everything that I installed in cydia to see if that works. Is there a way to uninstall and then reinstall every cydia download at once?

Thanks
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
sports96 said:
I uninstalled Activator which uninstalled SBsettings and still nothing. What is the best was to uninstall everything that I installed in cydia to see if that works. Is there a way to uninstall and then reinstall every cydia download at once?

Thanks

Yes.

Just remove Mobile Substrate.
It will remove all Cydia tweaks. Maybe not all, but only the ones that modify system settings.

Remove Mobile Substrate..and it will remove a lot of things. DO NOT stop this process!!!!

Let it finish and tap restart springboard/reboot device.

Then see if your button works.
 
OP
S

sports96

New Member
Joined
Mar 20, 2012
Messages
21
Reaction score
0
How do I reinstall the cydia apps after this?
 
Top