What's new

iPhone 4S camera - multiple faces detection prevents photos being taken (no shutter)

rrabbit

New Member
Joined
Jun 17, 2012
Messages
2
Reaction score
0
Apologies if this has been answered, but I searched the forum and did not find it.

My daughter has an iPhone 4S, purchased new in Dec 2011. All worked fine until the latest fw update. Now, when trying to take pictures with two people in the frame, the camera will highlight in green rectangles the faces, but will just refuse to take the photo! The moment it gets pointed somewhere else, where there are no faces, it snaps a photo by itself! We tried inside and outside lighting conditions, different backgrounds, flash and no flash, no luck - the moment it detects two faces it becomes like possessed and will not shutter.
Trying photos of landscape works just fine.

She called customer service at Apple, and nobody wanted to help because was past 90 days. They said the one year warranty applies only to HW (!), and encouraged her to "search the problem online".

She is not oriented towards SW and HW, I on the other hand am - this is the reason why I am posting this on her behalf. I am not an iPhone person, so I lack the skills in IOS (I do know intimately Android, Linux and Windows though).

Anyone, please, any ideas? Anyone else who observed the problem? Right now it seems she's stuck with an iPhone 4S that refuses to take photos and APPLE CS will not help or acknowledge the problem (we're in Calgary, Canada).

Thank you all.
 
OP
R

rrabbit

New Member
Joined
Jun 17, 2012
Messages
2
Reaction score
0
* UPDATE - Life's Good (pun intended) *

OK, I took the phone and I started a troubleshooting process to try to understand what's going on... and I believe I found a SW bug, here it is:

- if the phone is locked and you go into picture taking WITHOUT unlocking it (i.e. use the slide move) - it will experience the problem with multiple face detection every time, and will refuse to take photos, and occasionally freeze; if there's only one face detected, or no faces at all - it will take the snapshot! Front or back camera, lighting conditions, flash or not - seem to have no effect. Sometimes it worked for 3 faces detected.

- if the phone is locked and you FIRST unlock it and then go to picture taking mode (via the app icon), it will work just fine, every single time.

It seems that under two faces detect, the photo application goes into a portion of the code where the shutter will still be subject to the lock. Weird, but for some reason, this is indeed linked to the number of detected faces - I checked with dozens of photos and operation modes and confirmed this bug.

It would be interesting to see if others experience the same behavior.

In any case, this investigation allowed me to find a better app for the camera, and all is well now. I just hope other frustrated users experiencing this problem, will find my post and clear things out.

I also hope APPLE will eventually ack this problem and correct it - but I remain thoroughly disappointed with their customer service.

Cheers to all!
 

Most reactions

Top