What's new

iPhone 3G stuck in recovery/DFU, can't restore whatsoever - ERROR 6


New Member
Sep 20, 2012
Reaction score

I have an iPhone 3G I've purchased from a neighbor a few days ago. After he gave it to me I wanted to update it to the newest firmware (4.2.1 and I wasn't sure what firmware was on it before).
I'm not sure how but somehow I got to a point where I was in a recovery mode. I got stuck into it, and I can't get out from it now, and I can't install or restore any firmware.

I tried once, got ERROR 21. Fixed it (Firewall apparently), so the second time I got error 37. Once I fixed it I got Error 6. Each time I get other error.
I DID EVERYTHING! I followed every manual to troubleshoot by Apple or any other apple-fan website. I opened ports, updated Windows and ESET Anti-Virus, tried with disabled anti-virus, tried with deleted anti-virus, tried different network, tried through Wifi, tried through LAN, tried through my my phone (as a modem), tried with 5 different cables (4 originals by Apple, 1 from eBay), tried different USB ports, tried 3 different computers (which one of them was after fresh install of Windows 7 and iTunes), updated iTunes, downloaded the ipsw manualy myself and did shift+restore, tried from recovery mode and DFU mode.

Right now I got to a point where it reaches almost the end of the process, where in iTunes it says "verifying" and then it gives the error (Only error 6 now, the other error have been related to antivirus i guess and that's gone now so...)

I tried around 30-40 restores since yesterday, I've read hundreds of threads online and I can't seem to find a solution. I come to you as a final attempt to save it. Please help!

I'm adding a video of the process, in which you can also see I'm in pwned DFU mode this time:

Video -

Thank you in advanced :)
Last edited by a moderator:

Latest posts