What's new

How to restore a bricked iphone 4 running ios 7.0.4


New Member
Aug 13, 2014
Reaction score
I have an iphone 4 running ios 7.0.4 and I jailbroke it. I also saved the shsh blobs for it. When i was using cydia I accidentally removed a cydia package. That package must've been important because my phone shut off and went into this apple boot loop. Now usually when this happens you just hold the volume(+) button while you turn it on and then you can go to cydia and disable mobile substrate. But when i tried that my phone just shuts off and I know my volume up button is working. So then said let me just restore the damn thing and loose all my files, so i used itunes and i kept getting error 21 and other numbers. Then i heard about tinyumbrella so i tried to start TSS Server then restore and it would always give me error 11. I also tried to fix recovery but it would just show a black screen with scrolling white text saying greenpoison initialized and unable to find gbdevlist and then it just goes back to the apple logo. I have literally tried everything and i have shsh blobs for 7.0.4 so it's not like i didn't do anything right. I just need someone to figure this out. Thanks in advance.
Place the device into DFU mode and restore afresh to iOS 7.1.2. In-depth instructions can be found here.