What's new

Deleting Camera Roll Pictures

tbbxrr

New Member
Joined
Jul 19, 2010
Messages
3
Reaction score
0
Location
Webster, NY
I ran into a problem when I tried to delete pictures in the "Camera Roll." No matter how many times I touched the trash can in the lower right corner, nothing would happen. I had to go back to the "Camera Roll" and then view the picture to delete it. Then the deleted pictures appeared as black squares.

Later after powering off the iPhone, the black squares were gone. BUT I could not transfer new pictures to my MacBookPro using iPhoto nor ImageCapture. Both indicated that there were 7 (the number of black squares) jpgs still in the Camera Roll. iPhoto gave an error message that the files were "unreadable" and unrecognized and not contain valid data.

After a sleepless night, I connected the iPhone to my other computer and there was no problem! There was still the same problem when I connected to the first computer. I rebooted that computer and the problem disappeared.

I had checked the Apple discussion forum and noticed many people (both 3G and iPhone4) were having problems with the deletion from the Camera Roll and there is probably a need for a software fix.

In the course of trying to fix this, I restored my iPhone and in the process, lost the 2 iBooks I had just purchased. However, when I "repurchased" them, iTunes remembered that I had already bought them and resent them for free.
 

Gregoris

Administrator
Staff member
Joined
Jun 15, 2010
Messages
11,966
Reaction score
617
Location
United Kingdom
maybe try put the photos in iphoto to the trash on the right drop down list then try sync see what happens.. so it syncs from iphoto and if they are not there it will the the deleting thing from the phone also
 

Most reactions

Top