Contacts not syncing in iOS 12

Discussion in 'iOS 12' started by Michael Graubart, Sep 27, 2018.

  1. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    Phone: iPhone SE, iOS 12
    Computer:: Mac mini, macOS 10.13.6

    Since updating to iOS 12, my contacts sync between my Mac and iCloud.com, but not between iCloud and my phone. Both ways in each case. I have tried decoupling Contacts between phone and iCloud, waiting for a while and then switching Contacts on again in Settings/iCloud, with no success. I am loth to switch off iCloud altogether on the phone because of the time it would take to reload all photos, etc., but will do do if that is the only cure.

    I should be very grateful for help or advice.
     
  2. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    I realize that I am confused about settings on my phone. In Settings/Contacts, I have Gmail set as my default account. But surely that is for email, not for syncing of contacts? Should I, under Contacts, set it to iCloud?

    If the syncing of contacts does go via Gmail (why?), it might be relevant that around the same time as I updated my iOS to iOS 12 I also changed my Google password. But my Gmail email service is working correctly under the new password, so it seems unlikely that that is the cause of my Contacts problem.
     
  3. J. A.

    J. A. Super Moderator Staff Member

    Joined:
    Oct 26, 2014
    Messages:
    18,257
    Likes Received:
    23,540
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Gmail syncs emails, contacts, calendar entries, and notes.

    Where do you save your contacts? If you store them in your Gmail account, you’ll have to enable Contacts in your settings (Passwords & Accounts - Accounts - your Gmail account, enable Contacts).
     
  4. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    Thank you, J. A., for your quick reply.

    I do not, I am afraid, understand what you mean by 'Gmail syncs…'. Is it not the case that syncing between iphone and icloud goes via Apple and my mobile-phone provider (EE in my case) and not via Gmail, i.e. Google?

    My contacts appear in my Contacts app on my phone (and similarly on my Mac) and I do not store them anywhere else. Indeed, I do not know how this could be done.

    Since posting my question, and possibly because I tried once again to disable Contacts under iCloud on the phone, waiting a while and re-enabling it, I now find that new contacts do sync from my Mac, via iCloud, to my phone (so storage on the phone is not relevant), but they do not sync from my phone to iCloud (and therefore not to my Mac).
     
  5. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    PS: I have made two more discoveries:

    1. If, under Settings/Contacts/Default account, I change from Gmail to iCloud, do other things and then come back to this, it has by itself switched back to Gmail. I presume this is because Gmail is my default account for email.

    2. (But this is perhaps a Mac matter rather than an iPhone one): If, on my Mac, I open Contacts, under 'All iCloud' the contacts that I have recently added on my phone do not appear. But if I scroll right down, I find my gmail email address as a heading, and under this the errant contacts, including some older ones, do appear. So they got there via gmail and not via iCloud.

    How can I make them appear in my Contacts app on the Mac without changing my default email account (as well as the default account for Contacts) from gmail to iCloud?
     
  6. J. A.

    J. A. Super Moderator Staff Member

    Joined:
    Oct 26, 2014
    Messages:
    18,257
    Likes Received:
    23,540
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Gmail is one of the accounts that can sync contacts between devices.
    I see your default account for contacts is Gmail, so that’s why they don’t appear in iCloud. The contacts are saved to Gmail by default, they are not stored on your iPhone.

    On your Mac, open System Preferences and select Internet Accounts. If your Gmail address is not set up there, add it, and make sure Contacts is checkmarked. Then they should appear on your Mac as well.
     
  7. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    Thanks again, J. A. I am not very knowledgeable in these matters, but this begins to make sense to me. I have done what you say and my Gmail account is there, with Contacts checked. Moreover, when I recently changed my Google and Gmail password, I deleted the old account and set it up afresh with my new password. I have now done the same on my phone. But the situation remains unchanged: the new contacts I entered on my phone only appear on my Mac under my email address at the bottom of the side panel, and do not appear in my Contacts. app on the Mac.

    I also went to Settings/Passwords & Accounts on my phone and there to Website & App Passwords. There I found two different ones: one for Google.com and one for Gmail. These should be the same, so I made sure that both were the same and were my new one. This did not make any difference to the Contacts malfunction; I have just looked back there, and Gmail has disappeared altogether, leaving Google.com with the correct new password.

    This contacts malfunction is new. As I said earlier, the only things I have changed are 1. to update my phone to iOS 12 and 2. to change my Google/Gmail password.
     
  8. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    I have, I think, solved my problem.

    I said above that 'If, under Settings/Contacts/Default account, I change from Gmail to iCloud, do other things and then come back to this, it has by itself switched back to Gmail. I presume this is because Gmail is my default account for email.'

    This turns out to be incorrect. In Settings/Contacts, I have set the default account to iCloud, it has remained set throughout other manipulations and activities, and my contacts now sync to my Contacts app on my Mac.
     
    • Like Like x 2
  9. J. A.

    J. A. Super Moderator Staff Member

    Joined:
    Oct 26, 2014
    Messages:
    18,257
    Likes Received:
    23,540
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    I’m glad you’ve found the solution. :)
     
  10. Michael Graubart

    Michael Graubart Active Member

    Joined:
    Nov 2, 2013
    Messages:
    178
    Likes Received:
    42
    Trophy Points:
    28
    Location:
    London, UK.
    The annoying thing is that it was such a little thing and such an obvious thing. I should have guessed at the outset. But thanks for your advice and help.
     
  11. J. A.

    J. A. Super Moderator Staff Member

    Joined:
    Oct 26, 2014
    Messages:
    18,257
    Likes Received:
    23,540
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    You’re welcome.
     

Share This Page