What's new

When texting, iphone is adding a “1” before the number being texted. It won’t send

Puzzled

Member
Joined
Mar 26, 2013
Messages
56
Reaction score
10
iPhone 6s, ATT

I have been having issues sending texts. I am getting a message stating the number is not a proper 10 digit number. Yes, the number is correct. I end out calling the person with that same exact number.

Ex. In contacts, number displayed is (123)456-7890, in the send to of a text box it is 1(123)456)7890. That creates an 11 digit number and will not send. Gives a message to try a legit 10 phone number.

It happened just now when I tried to text my brother in another state, had to call him i stead.

A few weeks ago, I tried to text my brother-in-law, down the street. Happened again. It is his correct number. Had to call instead.

The phone is adding a “1” to front. There is no “1” in my contacts listing of that number.

I tried manually inserting that number in the text to box, because it is in my contacts, I have to select the person. I can’t leave it just as the number and scroll down, type the message and send it.

I also tried turning off dial assist in the phone settings. I also have SMS on. I also turned off my cellular so it would go over WiFi. It was the exact same result.

Also tried with my husband’s iPhone 5. I got the same message.

The recipient number is correct, so please do not say to check the contact. Both non-apple people’s contacts are correct. The 1 does not appear in their contact info, it is added when the text is sent. I thought maybe ATT, but turning cellular off netted the same result, an 11 digit number. The error message stating I need to enter a legitimate 10 digit number, shows that number with the 1 added to the front of the number.

I don’t know when this started, but it was not always like this.

No, a solution is not to delete the contact as one Google resoonse was. Cannot be deleting a contact before every text message.

Any idea why this is happening and an actual fix?

Thank you.
 
Last edited:

bear7962

Well-Known Member
Joined
Feb 8, 2013
Messages
1,844
Reaction score
1,131
I don’t have an answer for you, just some info. I have the 6+, also on AT &T. I just checked with two of the people I text. Neither has iPhones so it isn’t using iMessage. One had the 1 before the number in Contacts, the other didn’t. And it worked for both, as it used to for you. I hope someone can help you as I do not know what to suggest.
 
OP
P

Puzzled

Member
Joined
Mar 26, 2013
Messages
56
Reaction score
10
Bear7962, it seems to happen only when you start a thread with someone you have never texted before. It you have texted them before, it uses the same info as it did to send the previous message. That is what has been mentioned when googling. I never texted my brother or my brother-in-law before. They are really not into it.

I am getting annoyed. Someone said it has to do with carriers adding that 1 automatically to numbers when calling so you don’t have to. It is doing it for texting, too. Couldn’t find confirmation to that in ATT. The problem is, my brother-in-law lives down the street, no 1 would have been needed, unless cell phone numbers are different. I know on the old landlines the 1 was not needed to call him.

If anyone else has any explanation or info, please share it.
 

zstairlessone

Well-Known Member
Joined
Feb 12, 2012
Messages
2,643
Reaction score
4,219
I had an issue with someone I was replying to where, after months of working fine I was getting the same message. I deleted the message chain, deleted the contact and tried to send straight to a typed number - same problem. I reset my iPhone as new and the problem went away for about 2 weeks until I responded to a call with the automatic response and it happened again. Turns out it was getting corrupted when an automatic response (I was in a meeting) was texted to his iPhone. I'm not resetting my phones anymore for it, but will follow this thread in case a solution comes in.
 

bear7962

Well-Known Member
Joined
Feb 8, 2013
Messages
1,844
Reaction score
1,131
Bear7962, it seems to happen only when you start a thread with someone you have never texted before. It you have texted them before, it uses the same info as it did to send the previous message. That is what has been mentioned when googling. I never texted my brother or my brother-in-law before. They are really not into it.

I am getting annoyed. Someone said it has to do with carriers adding that 1 automatically to numbers when calling so you don’t have to. It is doing it for texting, too. Couldn’t find confirmation to that in ATT. The problem is, my brother-in-law lives down the street, no 1 would have been needed, unless cell phone numbers are different. I know on the old landlines the 1 was not needed to call him.

If anyone else has any explanation or info, please share it.
That isn’t my experience but good luck to you.
 

Atomic77

Active Member
Joined
Dec 26, 2018
Messages
114
Reaction score
91
I believe that for most numbers 1+area code is the standard process for making a call. I dont think you need it for local or non cell phone numbers.
 

bear7962

Well-Known Member
Joined
Feb 8, 2013
Messages
1,844
Reaction score
1,131
I believe that for most numbers 1+area code is the standard process for making a call. I dont think you need it for local or non cell phone numbers.
Actually AT&T requires 10 or more digits for texting, I would guess they all do. Regardless, Puzzled, try reseting your network settings and also, turn your phone off for a few minutes. I saw something elsewhere @texting issues and this helped. Anyway, it can’t hurt and is easier that re-entering contact info.
 

Most reactions

Latest posts

Top