What's new

Unwanted capitalisation

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
My phone is an iPhone 5s.

I use Text Replacement (in Settings > General > Keyboard) for phrases like my email address. Supposing my email address were <somebody.somewhere9@gmail.com> and I create a shortcut for that in Text Replacement, it always expands it to <Somebody.Somewhere9@gmail.com>, even if I turn Auto Capitalisation and spelling correction off. Can anyone suggest a way of getting round that?
 

Mickey330

Administrator
Staff member
Joined
Aug 12, 2011
Messages
1,845
Reaction score
363
Location
western NY state (USA)
My phone is an iPhone 5s.

I use Text Replacement (in Settings > General > Keyboard) for phrases like my email address. Supposing my email address were <somebody.somewhere9@gmail.com> and I create a shortcut for that in Text Replacement, it always expands it to <Somebody.Somewhere9@gmail.com>, even if I turn Auto Capitalisation and spelling correction off. Can anyone suggest a way of getting round that?

Have you tried fully deleting the shortcut from the cloud (so that's entirely gone). Then, re-input it, being extra careful to make the letters not capitalized.

While only you can verify this, but I imagine it's capitalized in your shortcuts (you can verify in Settings). So, in a way, it's not capitalizing, it's just entering what's there. Hopefully, re-creating it with lowercase will solve this.

By the way, it doesn't matter if an e-mail address is written with capital letters or not - it'll still work the same. As in, it's not case-specific.

Marilyn
 
OP
Michael Graubart

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
Have you tried fully deleting the shortcut from the cloud (so that's entirely gone). Then, re-input it, being extra careful to make the letters not capitalized.

While only you can verify this, but I imagine it's capitalized in your shortcuts (you can verify in Settings). So, in a way, it's not capitalizing, it's just entering what's there. Hopefully, re-creating it with lowercase will solve this.

By the way, it doesn't matter if an e-mail address is written with capital letters or not - it'll still work the same. As in, it's not case-specific.

Marilyn
Thanks, Marilyn. As a result of your suggestions, I have checked in Settings that there are no capitals, either in the phrases (my various email addresses) or in the corresponding shortcuts. I have also, rather than deleting and recreating an existing phrase and shortcut, tried creating a new email address and shortcut with lower-case letters throughout (a fictitious one, so as to make sure that there is no nefarious interaction with my name in Addresses on my phone or on my computer, linked by iCloud). Nothing of this kind has stopped the unwanted capitalisation.

I realize that capitalising an email address does not stop it working, but I have several times found that recipients of messages respond by saying 'We didn't realize that your email address is spelt with those capitals; we shall change our records', or words to that effect. I prefer to avoid creating this kind of misconception in my correspondents.
 
OP
Michael Graubart

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
Thanks, Marilyn. As a result of your suggestions, I have checked in Settings that there are no capitals, either in the phrases (my various email addresses) or in the corresponding shortcuts. I have also, rather than deleting and recreating an existing phrase and shortcut, tried creating a new email address and shortcut with lower-case letters throughout (a fictitious one, so as to make sure that there is no nefarious interaction with my name in Addresses on my phone or on my computer, linked by iCloud). Nothing of this kind has stopped the unwanted capitalisation.

I realize that capitalising an email address does not stop it working, but I have several times found that recipients of messages respond by saying 'We didn't realize that your email address is spelt with those capitals; we shall change our records', or words to that effect. I prefer to avoid creating this kind of misconception in my correspondents.

Problem solved! A curious solution, one that I first thought might be regarded as a bug, but now think might be an asset. Thank you, all, though,for suggestions.



This is the solution:



If the phrase has been saved with a capital first letter or capital letter after a dot, it will be expanded with a capital first letter in each place, regardless of whether one's saved shortcut has itself a capital first letter or no, and regardless of whether one types the shortcut with a capital or a lower-case first letter when using the Text Replacement in a document.



If the phrase has been saved with a lower-case first letter or lower-case letter after a dot, it will be expanded with a capital first letter in each place, regardless of whether one's saved shortcut has itself a capital first letter or not, if one types the shortcut with a capital letter when using the Text Replacement in a document.



If the phrase has been saved with a lower-case first letter or lower-case letter after a dot, it will be expanded with a lower-case first letter in each place, regardless of whether one's saved shortcut has itself a capital first letter or no, if one types the shortcut with a lower-case letter when using the Text Replacement in a document.



In other words, a capital first letter in the phrase will be expanded with a capital letter, regardless of how the shortcut is saved and regardless of how the shortcut is typed. A lower-case first letter in the phrase will be expanded according to whether the first letter of the shortcut is typed big or small when using the Text Replacement in a document, regardless of how the first letter of the shortcut was saved.


If the phrase (like an email address) has been saved with lower-case initial letters, it is how the shortcut is typed that determines the expansion, not the way the shortcut was saved.



These results were obtained with Auto Capitalization and Spelling Correction on. I have not tried any of this again with A.C. and/or S.C. off.
 
Top