What's new

T-Mobile iPhone 5 Won't Send MMS Messages (other than iMessage) - Probable Solution


Mar 22, 2011
Reaction score
EDIT: A new "solution". Basically, everything below is pointless if your T-Mobile iPhone gets the Carrier Settings Update out of the gate. If you don't get it immediately, and your APN settings are blank, plug into iTunes and it should push immediately.

The reason my wife's and mine didn't is because we restored from our previous iCloud backups that were on a different carrier. So for my wife, it took days to get the update pushed, but for me, I plugged into iTunes and it worked. So, just FYI... none of the info below is really necessary unless you can't get that carrier update from T-Mobile for some odd reason.

This is meant to offer a potential solution if you've just moved to T-Mobile and have one of their official iPhone 5's and it's completely unable to send MMS messages (other than through iMessage). We just moved, and my wife's phone had this problem out of the box, so I would imagine others will have it as well. I did not figure this out, I found it on the Apple support forums HERE - so thanks to "donsimmonstexas" for this info.

The problem:
Your shiny brand new, official T-Mobile iPhone 5 won't send MMS to anybody other than through iMessage - so it won't send "regular" MMS messages. The camera is grayed out, it's not an option from the Photos, etc. You've double checked everything... Cell Data is on, MMS is on, "Send as SMS" is enabled, etc. Nothing makes it work!

It appears, and from what donsimmonstexas said, that the latest iOS updates simply wiped out all of the APN settings. Like I said, ours was like this out of the box, so either T-Mobile didn't notice this or it was simply never on the device. Either way, here's how to double check that this is the case, and then fix it.

The solution (hopefully!):
Go to Settings > General > Cellular > (make sure it's all on) > Cellular Data Network - click it. This should bring up a window with APN settings for Cellular Data, MMS, and tethering. If it's all blank, then this is your problem and here's how it needs to be filled in:

Under Cellular Data Network:​
  • [*=1]APN: epc.tmobile.com[*=1]Username / Password: Leave blank
Under MMS:​
Under Internet Tethering:​
  • [*=1]APN: epc.tmobile.com

That's it - we didn't have to reboot or anything, it started working immediately. If by some chance you have all of that in your settings already, then check this thread for a few other suggestions.

Again - thank donsimmonstexas if this helps you, I'm just a messenger...

Last edited: