What's new

Stuck on Apple boot screen after Jailbreak?


New Member
Jul 16, 2010
Reaction score
Hi folks,

New to the Apple revolution and decided to Jailbreak my iphone4 but my phone now seems to get stuck with the Apple logo on start-up. Any ideas as to how to fix this?

I downloaded a theme and then iblacklist through Cydia,
it asked to reboot
I clicked yes(or something along those lines)
Phone switched itself off then has been stuck in the boot screen since.

I have tried the holding the home+lock/unlock button several times but it restarts and the same thing occurs.............No home screen :(

Itunes does not pick up phone nor does iphonebrowser.

I only Jailbroke today and wish i'd never bothered after 3hours of purgatory, i only wanted to see what all the fuss was about and install the Iblacklist app.

I'm quite windows literate but have never worked with Apple before so if anyone has any ideas or solutions i'd be a very happy bunny.

I've all my contacts on my sim card and photo's/music backed up with itunes so i wouldn't mind if it was wiped(tho i did like how i'd set everything up) Last ditch attempt but is it possible to do a fresh install?

I'm hoping for a very simple answer to this but 'cos it's Apple i cant see that happening.

Hope someone can help,
I have had this problem twice before on my 3GS. Both times I googles the issue to did the fix. If I remember correctly if has you pushing certain buttons while plugging it into the computer. You will be forced to restore to the latest firmware losing your jailbreak.