Problems with jailbreaking tools

Discussion in 'iPhone Jailbreaking' started by xavier1970, Mar 5, 2013.

  1. xavier1970

    xavier1970 New Member

    Joined:
    Jan 1, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Hi guysI finally jailbroke and unlocked my 3G iOS 4.2.1 BB 05.15.04 after long time trying different tools, operating systems and methods.There is definetely incompatibility of redsn0w with the different firmwares. For example I had to upgrade to the iPad bb 06.15.00 with a redsn0w 0.9.10b8 and downgrade it to 05.13.04 with 0.9.14b2. Other versions either bricked my iphone or just did nothing at all. It is really a challenge to perform a JB without making mistakes and spending hours of research and requesting the help of great people of the forums. I have other questions to ask.1. Why cant I have some versions of redsn0w (0.9.1xbx) run in WinXP SP3? When I run the app it pops up an error window with message saying my WinXP is missing an itunes dll library, this being a lie because the file is there, and end up not recognizing the firmwares and, of course, not doing the job. I had to all the JB and unlock process in a laptop running Win7Thanks for all cooperation
     
  2. Jmills87

    Jmills87 Well-Known Member

    Joined:
    Jul 28, 2011
    Messages:
    3,644
    Likes Received:
    163
    Trophy Points:
    63
    Location:
    The Land of Ice and Snow
    The reason you couldn't downgrade baseband with 0.9.10b8 was because that feature had not yet been developed when that version was released. The latest version of Redsn0w will always contain the most up to date tools and methods.

    If it's saying it's missing the DLL that usually means iTunes is not installed on that computer. Always run the latest version of Redsn0w in administrator mode and always have the most up to date version of iTunes installed.
     
  3. xavier1970

    xavier1970 New Member

    Joined:
    Jan 1, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    I tried different versions of redsn0w with the feature to upgrade and downgrade ipad bb and only 0.9.14b2 worked fine. No other one did the job right. I tried to downgrade with 0.915b3 and it just bricked the bb. They are NOT backward compatible, at least with old firmwares. And of course iTunes was installed. Something is wrong with WinXP and latest redsn0w versions
     
  4. Jmills87

    Jmills87 Well-Known Member

    Joined:
    Jul 28, 2011
    Messages:
    3,644
    Likes Received:
    163
    Trophy Points:
    63
    Location:
    The Land of Ice and Snow
    I've never had any problems upgrading or downgrading 3Gs baseband with 0.9.15, although I use Win7, not XP.
     
  5. willerz2

    willerz2 Super Moderator Staff Member

    Joined:
    Aug 15, 2012
    Messages:
    7,663
    Likes Received:
    655
    Trophy Points:
    113
    Location:
    New York
    Did you select the iOS 4.2.1 IPSW for the iPhone 3G before putting the device into DFU and downgrading your baseband? Jailbreaking, downgrading/flashing of the iPad Baseband, and anything that has to do with software changes must first have the iOS's IPSW selected before doing so.
     

Share This Page