What's new

Newbie here- Not receiving texts from android


New Member
Feb 26, 2015
Reaction score
i got my daughter an iphone 5 and activated it (sprint) and created a new apple id. however, when i text her from
my android the text go to her gmail account on the iphone and not the texting app. I googled this and find the reverse- people who had iphones and left apple can no longer receive texts unless they deregister their number with apple. I tried shutting of imessage – but that didn’t work, my texts still go to her email account. I went on apple and deregistered her number for imessaging – no luck there. her number is selected in the settings to receive texts. She gets texts properly from her other iphone friends. Any ideas?? thanks!!!
Welcome to iPhoneForums, eddieras!

Contact Sprint and make sure she has a text-messaging plan. That's necessary when she has to write to and receive from smartphones other than iPhones.
thanks - confirmed she has unlimited text
In Settings - Messages: is "Send as SMS" enabled? Also enable MMS Messaging.
Thanks everyone- i appreciate the quick responses. Send as SMS and MMS are both selected. The phone was activated yesterday at which time carrier settings were updated, but i will certainly try again when my daughter gets home from school. very frustrating! like she doesn't ignore our texts already - now they dump to her email- very convenient for her! :)
Try removing her email from your contact (if you have it setup that way).
Caesars- not sure i understand. do you mean remove her email from my contact on her iphone contacts (which are all gmail contacts)?
What Caesars mean to say, was:
On your Android, remove her email address. Leave her contact with the phone number only.

Do you use the built in texting app on your Android, or a different one when you send SMS to her?
i use regular android texting app- i just deleted her email from my contact and texted her. i really appreciate everyone's help- i'll report back
well- no go on that- i deleted her emails from my contact but my text still ended up in her emial on her iphone. i then deleted the entire thread on my phone and texted her again- same result. my text ends up in her gmail account on her iphone.
If her Gmail address is check marked on her iPhone in Settings - Messages - Send & Receive - You can be reached by iMessage at, try removing it from there.
Last edited:
Sounds like something in her gmail settings.

But I would double check first what her iphone has in Settings under Messages>Send and Receive. If she doesn't have her gmail address there, try adding it. You can have more than one address or number listed.
Last edited:
thanks again guys- here gmail is listed under send and receive. maybe i should call apple- i assume they'll charge for support - it is an older phone.