What's new

iphone 4 baseband bricked???

dentist india

New Member
Jan 26, 2015
Reaction score
hello, im new to this forum..
so i read this hackacitvate tool and i wanted to try it..i followed all the steps but i ended in trouble
i have a iPhone 4 which i think is bricked if someone can help me..its a iPhone 4 icloud locked...so i tired this tool called ios soft dev pack...which has the java exploit for iPhone 4...used ssh winscp deleted the setup.app from mnt 1 >application folder...then the hackactivate tool in ios softdev pack..used their tethered jailbreak 7.1 iphone model 3.1
and boom i unlocked the icloud...but every restart put me in apple logo loop so i had tethered jb every time...and their was no carrier ..since i deleted setup.app

now the issue so i thought i will restore with itunes to the stock firmware ios 7.1.2 and retry the jb...and itunes always stops restore where it says verify firmware with apple...and throws me error box 3194 and now im stuck at itunes restore mode..i can only dfu and restore mode...
did i brick my baseband??
is there any solution for it..like removing the logic board battery and reset..

please help me out guys!!
I'm sorry, but with an iCloud Activation Lock on that iPhone you'll never be able to get it fully working again without the Apple ID and password of the original owner. Every time the phone connects with Apple servers they will recognise your iPhone as being iCloud locked and won't let you proceed. This is why you can't restore the phone through iTunes.
but then how should i unlock it....now im just stuck at the apple logo and recovery mode itunes logo...dfu works...i think i didnt perseve the baseband while using ios softdevpack...there must be a way out of this..please help guys
Welcome to iPhoneForums, @dentist india!

I've deleted your other post on the same topic in a different thread. Besides fragmenting the conversation and making it hard to follow, duplicate posts are against our rules.

Please keep any discussion of your problem to this thread.
The 3194 error you keep receiving is normally the result of trying to put an incompatible firmware on your iPhone. There are two versions of iOS 7.1.2 for the iPhone 4, one for the GSM version and one for the CDMA version. Are you sure that you used the correct version?
yes im using the correct firmware...ipsw i downloaded is the correct one its gsm iphone4...iPhone3,1_7.1.2_11D257_Restore...and i have tired update and restore from itunes...and itunes takes the correct firmwareiPhone3,1_7.1.2_11D257_Restore while updating..but even that gave error..and stops and shoots that error exactly mid way restore...where itunes on the top shows verify firmware with apple
Is your iPhone 4 a late version, purchased in 2012? If so, I've found an iOS 7.1.2 download file for that version. Since the one you tried doesn't work, try this one instead: Download iOS 7.1.2 For iPhone iPad Direct Download Links Redmond Pie

You'll have to scroll down this page and select the link for the GSM Rev A iPhone 4 (it will automatically start downloading the file to your computer). I couldn't paste the direct link for the file - guess it's because it DOES lead to a direct download.

Regardless, hope this version of the software will help (and work).
Last edited:
it didnt work...i found other soultion from a guy from gsm he said to remve the L2 rf coil from the motherboard i went a shop and they removed it worked...but i lost my sim netwrk and wifi bluetooth i can only use it as a ipod now :( sad i think i have replace the motherboard..