What's new

ios 11: remove book from ibooks

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
iBooks on my iPhone (with iOS 11.2.5) syncs successfully with iBooks on my Mac via iCloud, but I cannot remove or hide unwanted books (in particular, earlier versions of the iPhone Users' Guide, which were free downloads from the iBook Store) from my phone.

I have found, read and tried all sorts of methods for doing this on the Web, but none seems to work with iOS 11.2.5. I should be grateful if someone could give me, or point me in the right direction for, iOS-11-specific instructions.
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
28,840
Reaction score
30,700
Location
Regina, Canada
Removing the books from iBooks on your phone can be done by tapping the edit button at the top right of the screen, then tapping the circle to the left of the book you wish to delete. Now tap the red delete button at the top left of the screen. as a guard against accidental deletion, a pop up will appear at the bottom of the screen. You have to tap the delete button in that pop up to delete the book.

If you want to delete a purchased or free book from your purchase history, it can't be done.
 

J. A.

Administrator
Staff member
Joined
Oct 26, 2014
Messages
22,098
Reaction score
32,707
Location
Apetlon, Austria
In My Books, tap “Select” at the top right:
126DE9AA-6B9E-4400-A4A1-37797812567B.jpeg

Then select a book. If it can be deleted, “Delete”, next to “Move” will be red. That way, you can remove a book that can be deleted.
If “Delete” is greyed out, select “Move”:
7DEE597A-30DF-4D4F-9C81-FD43F6939535.jpeg

In Move, scroll to the bottom to find “Hide iCloud Books”, and enable it.
C8157E28-F0C9-49D5-B654-FCB262C74311.jpeg


Hope that helps.
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
28,840
Reaction score
30,700
Location
Regina, Canada
In My Books, tap “Select” at the top right:
View attachment 39194
Then select a book. If it can be deleted, “Delete”, next to “Move” will be red. That way, you can remove a book that can be deleted.
If “Delete” is greyed out, select “Move”:
View attachment 39195
In Move, scroll to the bottom to find “Hide iCloud Books”, and enable it.
View attachment 39196

Hope that helps.
Mine is the same except the select button is called Edit.
 
OP
Michael Graubart

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
iBooks on my iPhone (with iOS 11.2.5) syncs successfully with iBooks on my Mac via iCloud, but I cannot remove or hide unwanted books (in particular, earlier versions of the iPhone Users' Guide, which were free downloads from the iBook Store) from my phone.

I have found, read and tried all sorts of methods for doing this on the Web, but none seems to work with iOS 11.2.5. I should be grateful if someone could give me, or point me in the right direction for, iOS-11-specific instructions.
Removing the books from iBooks on your phone can be done by tapping the edit button at the top right of the screen, then tapping the circle to the left of the book you wish to delete. Now tap the red delete button at the top left of the screen. as a guard against accidental deletion, a pop up will appear at the bottom of the screen. You have to tap the delete button in that pop up to delete the book.

If you want to delete a purchased or free book from your purchase history, it can't be done.

Thank you very much, SciFan57. Actually, I now see that on my phone the button at top right is called 'Select', but it works just as you have decribed it.
 
OP
Michael Graubart

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
In My Books, tap “Select” at the top right:
View attachment 39194
Then select a book. If it can be deleted, “Delete”, next to “Move” will be red. That way, you can remove a book that can be deleted.
If “Delete” is greyed out, select “Move”:
View attachment 39195
In Move, scroll to the bottom to find “Hide iCloud Books”, and enable it.
View attachment 39196

Hope that helps.

J. A., that's very helpful indeed — thank you very much. It has solved my [problem.
 

Most reactions

Latest posts

Top