What's new

Facetime not working - Dont want to update to iOS 7.1.1 to fix

Shane_O

New Member
Joined
Apr 27, 2014
Messages
4
Reaction score
0
Hi all,

I've got an iphone 4 currently on 7.0.3 11B511.

Facetime has suddenly started saying Connecting and just staying there and now its starting to say call failed after a few seconds.
From what ive read it says the certificates may be expired and i require an update. Thing is, I don't want to update as i want to jailbreak.

Can anyone give me any insight into what i should do??

I thought it used to be the case where you could pick the iOS by using the old shift+click restore trick??No??

I may try and restore the phone now but i dont see how this will be any different as i'll just be restoring to the same thing??

Any advice is appreciated.

P.S I have done all the tricks on youtube with activating my apple ID again through imessage and facetime and all that, changed the DNS on my wifi etc etc.

I still appreciate anything people can throw at me to try solve it.

Thanks
 

yukhalilsel

New Member
Joined
Apr 21, 2014
Messages
13
Reaction score
2
Ain't it possible for iPhone 4 to update to 7.0.4 with a custom ipsw?? Don't know for sure but I do know facetime does work on 7.0.4 for sure
 
OP
S

Shane_O

New Member
Joined
Apr 27, 2014
Messages
4
Reaction score
0
Ain't it possible for iPhone 4 to update to 7.0.4 with a custom ipsw?? Don't know for sure but I do know facetime does work on 7.0.4 for sure

Facetime was working on my phone on 7.0.3 so i wouldnt see why not on 7.0.4

As for updating on a custom ipsw, you tell me, thats my question.
 
OP
S

Shane_O

New Member
Joined
Apr 27, 2014
Messages
4
Reaction score
0
Yes, but going back to my original point, I DONT want to upgrade past 7.0.6 due to wanting to jailbreak so I need to know if and how I can update to 7.0.6 either from a fresh restore or a backup restore.The only reason i want to restore and or update to 7.0.6 is to try solve the issue with Facetime certificates.
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
31,043
Reaction score
35,806
Location
Regina, Canada
Yes, but going back to my original point, I DONT want to upgrade past 7.0.6 due to wanting to jailbreak so I need to know if and how I can update to 7.0.6 either from a fresh restore or a backup restore.The only reason i want to restore and or update to 7.0.6 is to try solve the issue with Facetime certificates.
Do you have blobs saved for iOS 7.0.6? If not, you can't upgrade to that iOS. If that is the case you will have 2 choices; upgrade to the latest iOS version with Facebook fixed and no jailbreak, or stay where you are with your jailbreak and no FaceTime.
 

simba4

Member
Joined
Dec 28, 2011
Messages
92
Reaction score
1
Or you can try ilex rat from Cydia!


Sent from my iPhone 5 using Tapatalk!
 
OP
S

Shane_O

New Member
Joined
Apr 27, 2014
Messages
4
Reaction score
0
why cant i just download ipsw 7.0.6, do a ctrl+shift and put that in?

Can i do that with 7.0.3 since i'm running that anyway?
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
why cant i just download ipsw 7.0.6, do a ctrl+shift and put that in?

Can i do that with 7.0.3 since i'm running that anyway?

Because Apple does not allow for custom IPSW restoration. You must have a custom IPSW made with stitched APTickets and SHSH Blobs so that the LimeRa1n exploit can be exploited to skip the verification/validation of your iOS firmware on your device. Even with blobs and APTickets, you have to manually stitch them yourself to a clean IPSW as no public utilities allow for the stitching of IPSWs on iOS 7. With no iOS hacking/exploiting experience, it's impossible to do.

You can restore to iOS 7.1 or 7.1.1 on the iPhone 4 and semi-tethered jailbreak it using GeekSn0w. The Facetime SSL certification port is not a priority as the level of difficulty in porting and successfully injecting an SSL certificate is extremely high, and hackers had time and time again, hinted and pushed for users to restore to the last compatible iOS that works with Evasi0n7 prior in the 2 full months leading up to the 7.1 release so that users have a fresh slate on their devices as well as the SSL fixes that came with iOS 7.0.6.
 

Ledsteplin

Well-Known Member
Joined
Oct 23, 2013
Messages
4,332
Reaction score
8,126
Location
Florence, AL
I thought FaceTime started with the 4s, not the 4. Or am I missing something here?
 
Last edited by a moderator:
Top