What's new

Terminal on iPhone 4 Tutorial

F1r3ant

New Member
Joined
Aug 2, 2010
Messages
23
Reaction score
0
Location
Va
Anyone who has jailbroken their iPhone 4 will have found that the verision of mobile terminal currently in cydia does not work. This version is not built for iphone 4. Here are the instructions to get a working copy on your iPhone.

What you'll need:
Jailbroken iPhone4
OpenSSH
WinScp
MobileTerminal v4.26

1. download mobile terminal v4.26 from Megaupload
2. SSH into your iphone and drop the .deb into /private/
3. Click on the black terminal icon (in winscp) and run the command "dpkg -i MobileTerminal-426.deb"
4. After it gets to "setting up mobileterminal (426), close out the window, respring your phone and the icon should show up
5. If it appears as a blank icon, drop Terminal.png into /private/var/stash/applications/terminal.app and rename it icon.png

Note: If you already have terminal installed before you start this tutorial, you should probably uninstall it. I think youll be ok if you dont

F1r3ant
 
Last edited:

beezy

New Member
Joined
Jun 20, 2010
Messages
367
Reaction score
0
I figured it out on my own with the help of google last night and I am a jailbreak n00b. It's no big deal if you are technically inclined and can follow directions. Unfortunately I am back in jail due to something fucking up my 3G connection. Might even stay in jail tbh.
 

wookiecarr

New Member
Joined
Jul 2, 2010
Messages
38
Reaction score
0
i download the one on xsellize repo for o.s4 worked a dream.

 
Last edited:
OP
F1r3ant

F1r3ant

New Member
Joined
Aug 2, 2010
Messages
23
Reaction score
0
Location
Va
i download the one on xsellize repo for o.s4 worked a dream.
I don't belive that that was available when I made this tutorial, but I might be wrong. Xsellize is kinda known for piracy, so I didnt have that repo installed. I encourage people to get it any way they like.
 

mr.witherspoone

New Member
Joined
Aug 5, 2010
Messages
1
Reaction score
0
Works like a charm.

... just make sure you don't have cydia running when you try it ...

iPhone:/private root# dpkg -i MobileTerminal-426.deb
dpkg: status database area is locked by another process
 
OP
F1r3ant

F1r3ant

New Member
Joined
Aug 2, 2010
Messages
23
Reaction score
0
Location
Va
Thanks to everyone whos made this such a successful thread
 

leif_one

New Member
Joined
Aug 12, 2010
Messages
4
Reaction score
0
Thanks F1r3ant!

Some of the download sites are a pain, but the terminal works great so far. Only thing is, the icon on my iPhone is kinda... blank looking. Any easy way to change the icon graphic to something meaningful?
 

jsarich

New Member
Joined
Aug 12, 2010
Messages
3
Reaction score
0
When running the command in WinSCP, I am receiving the error:

dpkg: dependency problems prevent configuration of mobileterminal:
mobileterminal depends on coreutils; however:
Package coreutils is not installed.
dpkg: error processing mobileterminal (--install):
dependency problems - leaving unconfigured

Where is the package coreutils and how do I get that installed?
 

jsarich

New Member
Joined
Aug 12, 2010
Messages
3
Reaction score
0
Nevermind. It seems there was a Cydia update for that that hadn't been installed yet.
 

jsarich

New Member
Joined
Aug 12, 2010
Messages
3
Reaction score
0
Once it is successfully installed, can I delete the .deb file from /private or is the app dependent on that file?
 

leif_one

New Member
Joined
Aug 12, 2010
Messages
4
Reaction score
0
I deleted the .deb file and both of the .gz files that were generated and it is working fine for me.
 

leif_one

New Member
Joined
Aug 12, 2010
Messages
4
Reaction score
0
Hey F1r3ant, I tried dropping that .png in there, deleting the original Icon.png, first via SSH as root, then using the iFile web server, tried naming it icon.png and Icon.png, checked all the file-protection bits looked in order, but I still just get a blank whitish icon even after shutting off and powering back on. Any ideas? Appreciate all your help bruddah!
 

Most reactions

Latest posts

Top