What's new

remote restore taking forever

Iph0tt0

New Member
Joined
Nov 22, 2010
Messages
5
Reaction score
0
Ok here's what, I have an old iPhone 4 the home button is broken and a few days ago the screen went blank but the phone was still on. It's one of the cases where the phone is functioning but it simply won't turn on, I knew it was on because I could receive calls and hear it ringing.



I plugged it into my mac book air to perform a restore but an error popped up saying that "find my phone" was active and I couldn't restore it because of that so I read some tutorials and went to iCloud and tried to restore it remotely (it's a procedure that deletes all data from the device).



I read it could take from "minutes to several hours" but the problem is that it's still showing the loading icon but more than two days have passed (>48 hours) and it's still there. I can't even force a hard reboot since the home button is broken.



Is there an alternative way to restore the phone?? :(

ps: Apple support sucks, they won't even let me post this in their golden forum :mad:
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
28,325
Reaction score
29,388
Location
Regina, Canada
It sounds like the backlight on your screen may have failed.
When using find my iPhone to remotely erase your iPhone, did you have both devices connected to power? BTW, find my iPhone just erases the data on your iPhone, it doesn't do a full restore. To get the phone working again, you'd still need to re-activate it, requiring a working screen. You may need to have the screen replaced before being able to proceed.
 
OP
I

Iph0tt0

New Member
Joined
Nov 22, 2010
Messages
5
Reaction score
0
I don't know why the screen is ok, works perfectly. It did stop working but as soon as I tried the iCloud method I was able to see the apple logo and now there is the ordinary icon it displays when it's loading, the problem is still the same, almost 3 days now and it's still displaying that and nothing more
 

Most reactions

Latest posts

Top