What's new

Why do I always receive errors in Cydia. Please help.

Timaayyy

New Member
Joined
Apr 11, 2011
Messages
2
Reaction score
0
No solution, but more info. Been tracking this problem since jailbreak 4.3.1 using sn0wbreeze on a windows 7 PC. At first it was amazing how much faster Cydia was until it went to fetch the unfetchable packages.gz file. You guys describe the problem exactly as it occurs for me as well - the same four failing repos, the same duplicate sources that cant be edited/removed. One post that I read indicated the where the repo files exist on the phone and instructions for deleting the files. I tried that remedy and no luck so I deleted more files that seemed to be related to the problem...no luck. Whenever I would delete the local repo files on the phone and then lauch Cydia, the folders and files are rebuilt when Cydia is launched. This might imply a problem with the server, but seems like there are not many people reporting a problem with this so I'm thinking it maybe a particular app or phone version. However my gut feeling is that this is a Cydia problem. Hopefully one of us finds the real solution bs we can get back to life.
 

Pocobear

New Member
Joined
Oct 23, 2010
Messages
373
Reaction score
3
Location
Virginia
FOUND ANSWER!! Yay, the author of PkgBackup, Jibril Gueye, sent me the instructions for curing this problem.

With Cydia not running, use your favorite file browser, such as iFile, and navigate to here;
/var/lib/cydia/metadata.plist and delete the metadata.plist file.

Restart Cydia and let it update. It will install all the standard sources, if you need any other sources, you may need to install them manually.

It worked fine on my iPad.
 

Timaayyy

New Member
Joined
Apr 11, 2011
Messages
2
Reaction score
0
thank you, thank you, thank you....I've been chasing this for hours and have re-jailbroken my phone and now can't get the phone to work. The only reason I did this is that I saw another blog that said that they were able to get it to work by using sn0wbreeze 2.5.1 (this was just released in the past few days) so it seemed plausible....damn, if only I had waited. Thank you Pocobear for getting down to the real deal....I had a feeling it had to do with Pkgbackup when I re-jailbroke and notice Cydia was fine until I did a restore from Pkgbackup....now I just have to figure out how to get this sucker to work as a phone again. Great Job!
 
OP
X

xfuz1on

New Member
Joined
Apr 7, 2011
Messages
26
Reaction score
0
Wow too late for me :( I got fed up with it and restored and rejailbroke my phone haha :X boo ..
 

dmitchstevens

New Member
Joined
Mar 6, 2011
Messages
176
Reaction score
1
Location
ky
After many restores and frustrations I have stumbled upon the fix. You will need to apps Cyfix and mobile terminal both from cydia. After you dl those watch the vid here. I have included. [ame="http://www.youtube.com/watch?v=9p9gFL4i9bo"]YouTube - cydia errors[/ame]
 

dmitchstevens

New Member
Joined
Mar 6, 2011
Messages
176
Reaction score
1
Location
ky
I could never get my big b repo back until i found this sweet little fix. i felt so stupid after this lol [ame=http://www.youtube.com/watch?v=QEk2-ZpxecM]YouTube - big boss repo disappears well learn to add back[/ame]
 

Most reactions

Latest posts

Top