What's new

Urgent Help - All pre-installed apps missing after jailbreak


New Member
Dec 3, 2010
Reaction score

I need urgent help from some experts to get my phone working.

I got a new iphone 4 (with iOs 4.1) last week and tried to jailbreak it yesterday evening using Greenpois0n.

It completed successfully and I got loader to install Cydia. After I launched Cydia, it started re-organization. At that moment, I accidently rebooted the phone. After reboot, I lost all the default apps (Safari, Mail, iPod, Camera, Weather, Settings etc.). I can only see the apps that I installed after I got the phone. All pre-installed apps have disappeared. I tried spot search and no luck.

I tried to update it back to iOs 4.1 using iTunes but it does not let me do that.

I now have a jailbroken phone which has few apps that I had installed and Cydia. I can install new apps using Cydia.

Can anyone help me get rid of this situation and get phone back to default factory settings so that I can try jailbreak again?

I have already tried with iTunes to restore to 4.1 using ipsw file. It fails after giving error - Cannot be restored. This device is not eligible for the requested build.

Only option that I know to go back to 4.1 is to modify hosts file to point to Cydia server to look at my 4.1 SHSH and then restor to 4.1 using iTunes.

From my phone, I have uploaded SHSH using Cydia. It currently shows Pending TSS request. I need to wait for some time (may be a week - as per blogs I read) to do the next action.

I am not sure if using TinyUmbrella, I can do this quickly rightaway or not. Trying to read blogs to understand that. Any help would be appreciated.

Click the make my life easier button in cydia. Then restore using iTunes to 4.2.1. From there you can roll back to 4.1 as long as you make sure you press the button in cydia.

*edit* I belive tiny umbrella does the same thing...

I have already clicked that in Cydia. It shows pendign TSS request. I have to wait untill it shows SHSH saved on Cydia server.

I am thinking of using TinyUmbrella as I won't have to wait in that case.
rld77 - Were you able to get it fixed at all? I have the same/similiar problem.