What's new

TUTORIAL - Jailbreak IOS5 using redsn0w for beginners

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
delphem said:
Each time i jailbreak my iPhone and I download Winterboard it makes my iPhone respring every 5 sec and I have to redo everything and I tried to get Callbar and it did the same thing? Is anyone else having these problems? Or is it just me?

Just you. Something is conflicting with something.

I have CallBar and WinterBoard working fine together. Among many other tweaks.
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
delphem said:
Any ideas to what it may be then?

Depends on what you already have installed. Did you I stall something that has an old "Recent Changes" history. Or just does not say is I'd compatible with your iOS and device model?

You cannot installs "anything" from Cydia.
 

TromOrc

New Member
Joined
Apr 10, 2012
Messages
3
Reaction score
0
Hi,
My Iphone is the 3GS old bootrom original version 3.1.3 O2 UK bought on set/2009. I had unlock for the first time in 2009, since that i never update until, and I don´t f*** know why I have decide update to new 5.0.1. Said that, you must imaginate that I have backup of my precious ipsw and boobs shsh right? Wrong, I f*** don't know why i didn't backup. The problem is, the jailbreak is working fine, cydia is running propely but the unlock didn't work. Fact: I have move abroad to Brasil, my homeland. Despite this fact, the unlock program provide by ultrasnow didn't work. And I guess is because my baseband is the 05.16.05, I really don't remeber if was there or if I update in the process. I have travel for many forum and website and "learned" that the problem is my baseband 05.16.05. The solution(if we can call this solution) is update to Ipad baseband and lost the GPS function. I'm strong desagree with this "solution". So I didn't instaled this Ipad baseband and I still have my Iphone lock, but jailbreaked(I'm not sure if this expression exist!). So please how downgrade only the baseband? Actually my IOs is the 4.3.3 and the baseband is the 05.16.05, please help me!
 
OP
f4780y

f4780y

Super Moderator
Staff member
Joined
Apr 11, 2011
Messages
916
Reaction score
153
Location
Troon, Scotland
TromOrc said:
Hi,
My Iphone is the 3GS old bootrom original version 3.1.3 O2 UK bought on set/2009. I had unlock for the first time in 2009, since that i never update until, and I don´t f*** know why I have decide update to new 5.0.1. Said that, you must imaginate that I have backup of my precious ipsw and boobs shsh right? Wrong, I f*** don't know why i didn't backup. The problem is, the jailbreak is working fine, cydia is running propely but the unlock didn't work. Fact: I have move abroad to Brasil, my homeland. Despite this fact, the unlock program provide by ultrasnow didn't work. And I guess is because my baseband is the 05.16.05, I really don't remeber if was there or if I update in the process. I have travel for many forum and website and "learned" that the problem is my baseband 05.16.05. The solution(if we can call this solution) is update to Ipad baseband and lost the GPS function. I'm strong desagree with this "solution". So I didn't instaled this Ipad baseband and I still have my Iphone lock, but jailbreaked(I'm not sure if this expression exist!). So please how downgrade only the baseband? Actually my IOs is the 4.3.3 and the baseband is the 05.16.05, please help me!

Unfortunately, you cannot downgrade a baseband. That's why, if you rely on a software unlock via untrasn0w, you must be very careful to preserve the baseband whenever you update the device by using a custom firmware. Once you upgrade you cannot downgrade it again. Sorry. :(
 

delphem

New Member
Joined
Jan 10, 2012
Messages
12
Reaction score
0
Depends on what you already have installed. Did you I stall something that has an old "Recent Changes" history. Or just does not say is I'd compatible with your iOS and device model?

You cannot installs "anything" from Cydia.
It's only messing up with Winterboard and CallBar that's it...I am using the correct versions with no changes
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
delphem said:
It's only messing up with Winterboard and CallBar that's it...I am using the correct versions with no changes

What's only messing up with WinterBoard and CallBar? Sorry.
 

TromOrc

New Member
Joined
Apr 10, 2012
Messages
3
Reaction score
0
Unfortunately, you cannot downgrade a baseband. That's why, if you rely on a software unlock via untrasn0w, you must be very careful to preserve the baseband whenever you update the device by using a custom firmware. Once you upgrade you cannot downgrade it again. Sorry. :(

All right, I got. Thanks in advance. By the way, is this GPS fail will be fixed, I mean, probally the next jailbreak method will be able to fix this?(speculation?!)

Thanks for help me, very smooth the tutorial!
 
OP
f4780y

f4780y

Super Moderator
Staff member
Joined
Apr 11, 2011
Messages
916
Reaction score
153
Location
Troon, Scotland
TromOrc said:
All right, I got. Thanks in advance. By the way, is this GPS fail will be fixed, I mean, probally the next jailbreak method will be able to fix this?(speculation?!)

Thanks for help me, very smooth the tutorial!

No. AFAIK once you have the iPad baseband you will be stuck with it and the associated issues (including no GPS) forever. It really should only be a last resort kind of thing if you must have a working phone and no other options exist.
 

ebrahim_yusuf

Member
Joined
Feb 7, 2012
Messages
175
Reaction score
0
Location
Nairobi, Kenya
Too many pages to read..:/
Read the first 5, And don't get an answer so il just ask,.
I need to jailbreak an iPhone 4g on iOS 5.0.1.
1.Does redsnow auto detect that firmware?
2. Say it does not, do I need to download the 5.0 IPSW OR 5.01(my current iOS).. And if I point it to the IPSW, will it affect my unlock?
 

Thomasjtsi

Well-Known Member
Joined
Oct 25, 2011
Messages
7,523
Reaction score
451
Location
Missouri, USA
Too many pages to read..:/ Read the first 5, And don't get an answer so il just ask,. I need to jailbreak an iPhone 4g on iOS 5.0.1. 1.Does redsnow auto detect that firmware? 2. Say it does not, do I need to download the 5.0 IPSW OR 5.01(my current iOS).. And if I point it to the IPSW, will it affect my unlock?
I do believe the newest version of redsn0w will auto-detect your firmware. However, it's always a good practice to have your current IPSW file on hand. Of course you'll need the current iOS version you're running. No, pointing a JB too a specific IPSW will not affect your unlock. The only time your unlock will be affected by pointing to a specific IPSW file is when you're restoring or updating to it via iTunes.
 

ebrahim_yusuf

Member
Joined
Feb 7, 2012
Messages
175
Reaction score
0
Location
Nairobi, Kenya
just did a jailbreak on an iPhone 4s using Redsn0w 0.9.14b2 and i didn't even have to put it into DFU mode.. I just clicked "jailbreak" and everything was done in almost under a 2 minutes,.
hope it works the same on the iPhone 4G..
 
OP
f4780y

f4780y

Super Moderator
Staff member
Joined
Apr 11, 2011
Messages
916
Reaction score
153
Location
Troon, Scotland
just did a jailbreak on an iPhone 4s using Redsn0w 0.9.14b2 and i didn't even have to put it into DFU mode.. I just clicked "jailbreak" and everything was done in almost under a 2 minutes,.
hope it works the same on the iPhone 4G..

Yes, since this tutorial was written back in 2011 the process has improved. redsn0w is able to "one-click" jailbreak for the right device and firmware combinations! :)
 
Last edited:

Most reactions

Top