What's new

Suddenly "No Service" with 3gs via AT&T prepaid

Illinoisjoe

New Member
Joined
Jul 2, 2012
Messages
3
Reaction score
0
Hi all, I've been using a hand-me-down iphone 3GS with a pay-as-you-go sim card from AT&T with no problems for about 6 months. It's not jailbroken or unlocked from AT&T or anything fancy like that. I never used data (besides wifi), and just paid $0.10/min for voice and got 200 sms for $5 a month. All told I paid a little more than $25/mo, which was a great deal for me.

About a week ago, my phone started constantly displaying "No service" no matter where I went, even in places where I'd had service before. I've tried all kinds of resets hard and soft to no avail. I called ATT and they of course said "We don't support the iPhone as a prepaid phone. Our network can't support it's complex operating system." Ha!

I suspect ATT finally figured out I was using an iPhone on their network somehow and nixed the service. I've reverted to my old sony ericsson "dumb" phone, but I'm pretty sad to abandon my iPhone. I had just refilled my account too so I have $88 left to spend on ATT before I can abandon them for T-Mobile (which is what I'm planning to do)

My questions: Has anyone else ever had this happen? Perhaps it's not ATT and I lost signal due to a legitimate hardware problem in my phone? If it has happened, is there anything I can do? I tried to reregister my SIM card but it didn't seem to work. Are there any phone settings I can tweak?

I haven't been able to find someone with a "real" ATT plan so I could swap sim cards with them and test the reception, but that is what I plan to do (all my friend seem to have new iPhones with microSIM cards now, so I can't do the swap).

I eagerly await the wisdom of the forum.
 
OP
I

Illinoisjoe

New Member
Joined
Jul 2, 2012
Messages
3
Reaction score
0
So much for eagerly awaiting: I paid a stoned undergrad $60 to fix my cracked screen and figure out if my antennae was broken. It was, and he replaced it. Problem solved.
 

xrayeyes

Well-Known Member
Joined
Jun 8, 2011
Messages
1,606
Reaction score
223
Location
Charlotte burb
Ummm, I don't see that you told us that you had a cracked screen...that might have given someone a clue to help you. :)

But, glad you got it fixed! Welcome to the forum!
 

Thomasjtsi

Well-Known Member
Joined
Oct 25, 2011
Messages
7,523
Reaction score
451
Location
Missouri, USA
I, too, like how it went from "Suddenly No service..." to having a cracked screen... LOL!!! Glad you got it sorted out either way. :)
 

Most reactions

Top