What's new

Personal Hotspot, w/verizon unlimited + tethering, breaks connection after one minute


New Member
May 24, 2011
Reaction score
For the last (about) two weeks, my iPhone 4, on Verizon's Unlimited Plan, with Tethering Plan enabled, breaks the USB and/or WiFi connection to the Win7 laptop AND the iPad WiFi connection after about one minute... consistently. The iOS is 5.0.1. The tethering option has functioned just fine up until this recent development.

The phone is Jailbroken, and the app, MyWi, a JB tethering app, works flawlessly. It will stay connected through MyWi indefinately. I can get up in the morning, bring the computer out of "sleep," and the tethering is enabled almost instantly.

For the Native Verizon Tethering Plan problem, I have tried a number of procedures on the iPhone, including Reset Network, Respring/Reboot/Reset procedures, disabling Mobile Substrate (Jailbrake functions). I have tried USB tethering to the computer only, as well as WiFi tethering to the computer and to the iPad. The problem persists and does not vary in the amount of connect time before the disconnect. I have disabled Auto-Lock, and there is a "No Sleep" type app installed.

The only way to get it back is to go to the iPhone, turn OFF, then ON the Mobile Hotspot function. A connect is reestablished for about 1 minute. I can watch the blue banner across the top blink off momentarily at 1 minute, blink back on for about 2 seconds, then off permanently again until cycling the Personal Hotspot setting on the phone.

The Personal Hotspot function on the iPhone has always been less reliable than the jailbrake app, MyWi, but never this consistently broken.

I have subscribed to the official Verizon Tethering Plan since the very beginning, in-spite of being jailbroken and having that tethering option also, because paying, at least in part, for that privilege, is the right thing to do. However, because Verizon only allows 2 GB of data for its tethering plan, I have been able to mootch a bit more through the normal unlimited data pool that the iPhone itself draws from. I'm not a data hog by any means, but my ONLY access to the Internet is by way of the iPhone. (I'm retired and an RV resident, doing full-time State Parks Hosting in Oregon.)

Does this issue ring a bell with anyone else here? Thanks!

Last edited:

Most reactions

Latest posts