What's new

Iphone 4S will not restore

valdrin fetoshi

New Member
Dec 7, 2012
Reaction score
Hello everyone. Im having errors on iTunes while restoring iPhone 4S at iOS 7.1.

I was trying to update from Settings/General/Software Update, while the phone was working and it was 30% or more battery, but then it turned off and didn't booted on again.
When I take it off Recovery mode, its just flashing the Apple logo...

Im using Windows7 Professional for Restore process. I have corrected the hosts file, but still the same error :(

Can anyone tell me what to do ?

Have you tried putting your device in DFU mode? Connect your iPhone to the computer, and make sure it is OFF AFTER YOU CONNECT IT, and put it in DFU mode. To achieve DFU mode, follow these steps:

- Press the Power button for 5 seconds.
- Keep holding the power button, but without releasing, press and hold the Home button at the same time, for 15 seconds. You should see the screen turn off.
- After 15 seconds, release the power button AND KEEP HOLDING the home button for 15 more seconds, or until you hear the sound of your device connecting to the computer.

At this point, open iTunes, and you should see something like, "This device is in DFU/Recovery mode, please restore it"
Click Restore/Restore and Update, and let it do its thing. You might want to restore the host file to its original state before doing this. You will lose all of your data, unless you did a backup before the iPhone ran into problems. Please reply on how well you do, after this process is done. If you have any questions, feel free to ask.

(I am not a robot, just type like one.)