What's new

Iphone 4 not syncing to Itunes after jailbreakme hack

littledochawk

New Member
Joined
Sep 13, 2010
Messages
37
Reaction score
0
Location
Washington
as the title sais, I did the jaibreakme hack on my phone and since then I have not been able to sync with itunes at all.

I've tried uninstalling and re-installing itunes, rebooting phone, and uninstalling drivers on machine and re-installing. Nothing is working...

I can't take it to apple because it is jailbroken, and I can't un-jailbreak it because I cannot connect to my computer.

Anyone have advice on this issue?

Any and all help will be much appreciated, thx!
 
you try erasing all contents and setting? that might make you lose the JB to get going again
 
I was really hoping that there was another option other than losing all my contacts and info.

I have done a setting only reset, and that still gave no help.
 
but you synced it before your jailbreak correct? so shouldnt all your contacts still be on itunes? unless you added a lot after you did the JB
 
I guess that's right, I have added a few after the sync. And yes it did sync prior to the jailbreak. But now that I have though about it a bit, it even synced once after the jailbreak. So now that makes me even more confused.

I wonder if it is a problem with the phone itself.

I have not done a restore before so I don't know how it works, I have a finance app on my phone that stores my transactions, would this information be stored in previous sync's?

It seems that my only option is to restore from the phone and hope that it syncs after that, otherwise it's time to take it in to apple?
 
if the app connects to a website on the internet, because basically all apps are are shorcuts to programs or internet pages, so if it connects to the internet and loads up from there then yes it will save, if its done manually, im not to sure about that, and if it doesnt sync after you do the full restore thing then yeah take it to apple, have you tried to sync it in DFU mode yet though? by that i mean if your computer recognizes it
 
I've tried putting it into DFU a few times, but to no avail. I'm not sure I'm doing it right.
 
yep I've done that step for step, didn't fix anything.
On my windows 7 machine it is showing up in the device manager as a multimedia audio controller.
On windows XP it doesn't even show up in the device manager.

I've searched everywhere looking to see if anyone has run into a similar error, and have found nothing.
 
man what i would do it do the full contents and settings reset =\, and if all else fails apple store
 
ok, so just an update on this one.

I did a reset from inside the settings menu on my iphone, and it bricked it.
It is stuck in a infinite rebooting loop, I was able to get it to show the screen that says to connect to itunes but still there was no response when it was plugged into my computer.

I contacted apple care, which I had purchased their plan when I bought the phone, and they are sending me a replacement within three business days.

This is all well and good but I am worried that they will be sending out a phone with the latest firmware installed, is this correct?

I really hope that they dont send me a phone with 4.1 installed but I fear that this is what I'll be getting.
 
Last edited:
something was definetly wrong with the phone, and I think trying to reset it was just the icing on the cake at that point. I was even able to get the connect to itunes screen to show up on that phone and it still wouldn't connect. I got tracking on my new phone and it should be in today, so at least apple took care of me!
 
bummer, just got the phone. They shipped it with 4.0.2, looks like I'm now just waiting paitently. lol
 
Back
Top