What's new

iPhone 3gs unique WiFi problem??


New Member
Dec 10, 2012
Reaction score
hey so i have an iphone 3gs running 4.1 software, 05.13.04 baseband; ive jailbroken the device using limera1n and unlocked with ultrasn0w

oddly enough it appears when i unlocked with ultrasn0w my baseband suddenly changed from 5.13.04 to 5.14.02 ?? i made sure to install using 5.13.04 baseband

currently cellular data and phone calls are working fine (rogers network)

the problem is, the phone will only detect and connect to the wifi (happens to be a tim hortons hotspot) that i used to jailbreak and unlock the phone on

the phone will only detect (and works fine at any range) to the one specific hotspot

ive searched high and low for solutions but all in vain, i have tried the usual methods:

1) resetting network settings, and all settings
2) draining battery power
3) frezzer method
4) restored to legit firmware versions 4.0, 4.1, 5.1.1 and 6.0 and updated and downgraded from ipad baseband (my model can do this!)
5) rejailbroke and reunlocked the phone several times on 4.0 and 4.1
6) tried configuration utility provided by apple
7) tried WiFiFoFum (detects other networks in a -80+ range but can never connect, and are usually listed as private)

it seems obvious that this a hardware issue, but why then does the timhortons hotspot work fine? and all cellular functions are fine (i do not have a data plan!) almost as if the hotspots configuration is burnt into the hardware permanently!

also this hotspot denies access to the bigboss repo so i have to manually add apps from the repo

this is driving me nuts.. considering i have to drive back and sit at the tims looking like a mooch to try different things on the phone!

also, it may be worthwhile to note that the iphone works with any wifi at extremely close range!


Most reactions

Latest posts