What's new

Can no longer modify my Contacts AddressBook Permission Issue

iphonefr33k

Member
Joined
Jun 5, 2012
Messages
91
Reaction score
2
I ran into some problem and had to backup my files using both iExplorer and iFunBox. One of them did not allow m to copy the AddressBook folder back to the iPhone so I created the folder and obvioulsy forgot all the permissions for the folder and all of its contents.

I know how to use chown and chmod in OSX. For example the Extensions folder is, chown -R 0:0 Extensions/* and chmod -R 755 Extensions/*

I don't think the AddressBook ownership and permissions on the iPhone 4s are the same as on MAC OSX? I think the AddressBook ownership is root:mobile and permissions in octal are 700? And its files inside are mobile:mobile and permissions are 644, is that correct?

I tried that with no luck, I still cannot edit my AddressBook?

For the files once in the AddressBook I did this:

chown -R mobile:mobile *
chmod -R 644 *

I read on Sinful that the AddressBook.sqlitedb needs to be root:mobile??

I tried all of that nothing seems to be allowing me to modify my contacts? I must have the permissions wrong on one of the files?

Here is the list of files and 1 folder inside the AddressBook:

AddressBook.sqlitedb
AddressBook.sqlitedb-shm
AddressBook.sqlitedb-wal
AddressBookImages.sqlitedb
AddressBookImages.sqlitedb-shm
AddressBookImages.sqlitedb-wal

And a folder sitting in there, have no idea what that is for and what permissions it needs??

Folder>>>> IntellibornLicenses

Files inside that folder are:

.syncid
MyWi 4.09fd509332db6b628fdf820ae7d2db1ed3adfc30g


Thanks


EDITED 7-19-13

I decided to just delete all the files since I had a backup of my contacts on iCloud. Once I opened contacts after a hard reboot I could see the ownership and permissions. All the files are mobile:mobile and the permissions are user: read,write Group: read and World: read which can be set with chmod -R 644!! I can only go by what I read on Sinful that the AddressBook is mobile:mobile for ownership and permissions are read,write,execute octal 700.

I still have no idea though what the permission and ownership should be for IntellibornLicenses folder and its contents.
 
Last edited:

Most reactions

Top