Imessage confusion with appleid email address and phone numbers

Discussion in 'iOS Forum' started by deltaindia, Oct 23, 2011.

  1. deltaindia
    Offline

    deltaindia New Member

    Joined:
    Oct 17, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have a 3GS and iPad 2. My partner has iphone4 and iPad 2. All at IOS5

    If I send a message from my iPhone to his iPhone4 using his phone number it goes via iMessage to the iphone4 only.
    If I sent a message from my iPad to his iPhone4 using his phone number, the iPad likes that ( some how knows that it's mapped to his apple I'd?) and he received on his iPhone4 AND iPad from user@appleID.com not his phone number.

    So the confusion starts. On his iPhone4 he has two threads, one from my phone number and one from my apple I'd. Depending on which he replies to, one I get on my iPad, one I don't.

    Is this behaviour expected? It's confusing the hell out of us both...

    Apple seems t have worked out that my phone number is tied to my apple ID, so why then do we get separate iMessages appearing. Why not merge them. And further more, if my iPhone gets an iMessage sent to my phone number, why doesn't that get sent to my iPad too?

    Anyone help?
  2. michaelwoodbury
    Offline

    michaelwoodbury New Member

    Joined:
    Oct 27, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I am having the exact same problem with iPhone and iPod! Please let me know if you find out how to fix it.
  3. Yptcn
    Offline

    Yptcn New Member

    Joined:
    Oct 7, 2011
    Messages:
    137
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Where ever you go ,there you are !
    I had the same problem and figured it out.. In Settings go to Messages , there you must choose you Apple id instead of phone number .
    You will then have all your messages on iPhone and iPad. It worked for me !
  4. deltaindia
    Offline

    deltaindia New Member

    Joined:
    Oct 17, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Where specifically should I change this? Under "receive at"? Then where? Caller ID?

    Thanks
  5. michaelwoodbury
    Offline

    michaelwoodbury New Member

    Joined:
    Oct 27, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    He must be talking about the "Caller ID" option. However, for me this is not the answer. With your email instead of phone number as the caller id, the messages with your friends will show up as your email. Your sms texts will still come from your phone number and be a separate conversation. This does allow the conversations to sync between devices but the phone's sync with imessage and regular texts.
  6. michaelwoodbury
    Offline

    michaelwoodbury New Member

    Joined:
    Oct 27, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    *Allows sync between devices but undoes the sync on your phone between imessage and regular text
  7. Yptcn
    Offline

    Yptcn New Member

    Joined:
    Oct 7, 2011
    Messages:
    137
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Where ever you go ,there you are !
    On your Phone : Settings ☞ Received At ☞ Then change to your email instead of your phone number .
    Only then will your messages be sync on both iPhone and iPad.
    Hope this helps ...
  8. Yptcn
    Offline

    Yptcn New Member

    Joined:
    Oct 7, 2011
    Messages:
    137
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Where ever you go ,there you are !
    I'm not to sure I understand what you are saying ....sorry , I'm french....nobody's perfect ;-)

    On my phone when I want to send a message , I put in the name of my contact . When putting phone number :if it shows in blue that means my contact has an iPhone (With iOS5) , if green then the message will go as a regular SMS.

    With email address ,the same color code applies . If blue ☞ iMessage . If green ☞ MMS .

Share This Page