iMessage internationally

Discussion in 'iPhone iOS' started by pjbear77, Dec 23, 2011.

  1. pjbear77

    pjbear77 New Member

    Joined:
    Dec 23, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I did a few searches, and saw some related posts..just nothing that asnwered my specific question. :messages:
    I am trying to send an iMessage to a friend in Italy, (I'm in the US) I've used his number with the country code and international code (011) also with out the international code
    and niether result in an iMessage. It stays as an SMS. He does have iMessage turned on.
    Any ideas?
     
  2. thewitt

    thewitt Member

    Joined:
    Oct 5, 2011
    Messages:
    400
    Likes Received:
    16
    Trophy Points:
    18
    You need to send to his registered iMessage address, email or phone number doesn't matter. Start in Contacts and select Send Message. Select the iMessage destination. The phone number needs to include the + sign and the country code.

    iMessage doesn't care what country you are in. I use it between a dozen different countries every day.
     
  3. mfterka

    mfterka Member

    Joined:
    Aug 7, 2011
    Messages:
    132
    Likes Received:
    2
    Trophy Points:
    18
    iMessages show in a different color do they not ? Blue I think? iOS determines automatically if a text from your iPhone heading to another phone number is another iDevice andso it ends up being an iMessage?
     
  4. rope_zg

    rope_zg New Member

    Joined:
    Nov 29, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    When you add new contact or edit an existing one you should specify that he/she uses an iDevice (iphone) by entering phone number in a proper field.

    Otherwise your messages will be sent as SMS until the person replies you and
    then you'll continue to use iMessages.
     
  5. rope_zg

    rope_zg New Member

    Joined:
    Nov 29, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Here's an image explaining my previous post. Yes, sms messages are green and iMessages are blue. Cheers.
     

    Attached Files:

  6. mfterka

    mfterka Member

    Joined:
    Aug 7, 2011
    Messages:
    132
    Likes Received:
    2
    Trophy Points:
    18

    Yeah makes sense - just have to properly organize your contacts when setting them up.
     
  7. rubyred2005

    rubyred2005 New Member

    Joined:
    Jan 23, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    hi all
    Been all over trying to find a solution to my problem....
    I have an old 3gs, but upgraded to iOS 5.0.1 a few months back, but only recently turned on the Imessage.
    Imessage works fine for my friends in sweden, where i live - but i cant get it to work for a friend who lives in the uk.

    - i have number saved with + then international dialling code
    - the number is saved in contacts as an iphone number.
    - i have tried to text directly from the contacts app by using send message
    - i have changed my dns to 8.8.8
    - have switched on & off, deleted & then added again as new contact

    My friend also has no problems messaging his friends in the uk - its only my number that wont work.
    The strangest thing is that I have turned off the sms option in messenger, but i can still text my friend. When i select his name, the bubble remains green :messages: !!!!!!!

    Any more suggestions ? would be really greatful as now its just making me plain mad !!!!

    Getting iphone 4 in about 8 weeks - maybe i should suck it up till then ???????
     
  8. bab2010

    bab2010 Well-Known Member

    Joined:
    Feb 6, 2011
    Messages:
    7,025
    Likes Received:
    63
    Trophy Points:
    48
    Location:
    Beijing
    Why don't you simply add their Apple ID email address to their contact info in your iPhone?
     
  9. rubyred2005

    rubyred2005 New Member

    Joined:
    Jan 23, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I've done that as well :( - still doesnt work
     
  10. photoworks

    photoworks New Member

    Joined:
    Feb 2, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have been using iMessage for some time, and i notice questionable behaviors that i don't understand




    I am in the US with ATT on iPhone 4s, and sending iMessage to a friend on ATT iPhone 4s traveling outside the US.


    The iMessage will never be delivered on somebody previously using iMassages and now Traveling and forced to use SMS in rooming.


    Why is iMessages not sending them to SMS number ?




    So i turned off iMessage to use SMS, and it all worked fine!




    Another problem came up!


    After using the iPad on IOS 5 i was getting the iMessage on the iPad too, but after turning it off on the iPhone i was still getting messages on iMessage only iPad and not on SMS on iPhone..




    i think there is much improvement to be made on the Systems of iMessage, or explain the limitations
     

Share This Page



Search tags for this page
can i imessage internationally
,
can you imessage internationally
,
can you use imessage internationally
,

cannot imessage a foreign country

,
does imessage work internationally
,
how to imessage internationally
,
how to send imessage internationally
,
how to use imessage internationally
,
imessage international numbers
,
imessage not working internationally