Settings Problem

Discussion in 'iPhone Help' started by garnet408, Jun 15, 2019.

  1. garnet408

    garnet408 New Member

    Joined:
    Nov 7, 2013
    Messages:
    19
    Likes Received:
    7
    Trophy Points:
    3
    Recently my phone will not respond to attempts to change the "Show My Caller ID" setting. Several days ago, it took many, many tries. Today I can not change the setting at all. What I find troubling about the situation is that apparently this is the only setting that will not change. Would appreciate any insight. TIA
     
  2. J. A.

    J. A. Super Moderator Staff Member

    Joined:
    Oct 26, 2014
    Messages:
    17,523
    Likes Received:
    22,820
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Maybe there’s a carrier settings update. Go to Settings - General - About. If there’s an update available, you’ll get a popup after a few seconds.

    Or put your device into Airplane Mode for about 10 seconds, then turn this feature off again. Try changing “Show ...” again.

    It’s possible that removing the SIM card and inserting it again will do the trick.

    Also, make sure that date and time are correct (Settings - General - Date & Time).

    Another option would be resetting network settings (Settings - General - Reset - Reset Network Settings). You’ll have to set up Wi-Fi, ... again afterwards.
     
    • Like Like x 1
  3. garnet408

    garnet408 New Member

    Joined:
    Nov 7, 2013
    Messages:
    19
    Likes Received:
    7
    Trophy Points:
    3
    Thanks for the response. I will see if any of these suggestions help.
     
  4. garnet408

    garnet408 New Member

    Joined:
    Nov 7, 2013
    Messages:
    19
    Likes Received:
    7
    Trophy Points:
    3
    Well! At first the airplane mode action did not work. Then I installed the missing update (I had been delaying the update because I had seen (then never followed up) an article that warned against that update at the time. So I installed the update, no go, the circle just kept spinning. Then I tried airplane mode again. And voila! After the airplane mode, it worked again. Thanks bunches!
     
    • Like Like x 1
  5. J. A.

    J. A. Super Moderator Staff Member

    Joined:
    Oct 26, 2014
    Messages:
    17,523
    Likes Received:
    22,820
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Glad to help. :)
     

Share This Page