What's new

Wi-Fi: iPhone 3G does not always connect

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
I have Wi-Fi at home from the BT Home Hub that creates my broadband connection to my computer. I have set the Wi-Fi settings of my 'phone to connect automatically to my BT Wi-Fi, but occasionally this does not happen and I have to go to Settings>Wi Fi and tap on the name of the Wi-Fi network. This then immediately makes the connection, so it does not seem to be a temporary fault in the Wi-Fi provision itself that causes the automatic connection to fail.

This is a matter of some moment because if I fail to notice that the 'phone is not connected to Wi-Fi, anything I do on the 'phone drains the money in my pay-as-you-go mobile 'phone account. I should be grateful for any suggestions.
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
See if a hard reset resolves the issue. Also try resetting your network settings to start afresh. It's leaning more towards a software issue than a hardware issue from the looks of it


Sent from my iPad Mini via Tapa
 

bear7962

Well-Known Member
Joined
Feb 8, 2013
Messages
1,874
Reaction score
1,181
You can also set the phone to use data only ion wifi. That way, no surprised on your bill.
 
OP
Michael Graubart

Michael Graubart

Active Member
Joined
Nov 2, 2013
Messages
191
Reaction score
48
Location
London, UK.
Thank you both for your answers. But they raise two more questions:

1. Will a hard reset necessitate redoing all my settings afterwards?

2. I cannot find a way of setting the 'phone to receive data only via wi-fi in the users' manual that I have downloaded from the Net. Bearing in mind that my 'phone is a 3G (not 3GS) with iOS 4.2.1, how can I set it like that if I should want to?

Thanks in anticipation of replies, and best wishes.
 
Last edited:

bear7962

Well-Known Member
Joined
Feb 8, 2013
Messages
1,874
Reaction score
1,181
Settings>General> Cellular>Cellular data, toggle that off.
 

Most reactions

Top