What's new

Upgrading Assistance

Static Sloth

New Member
Joined
Feb 13, 2013
Messages
1
Reaction score
0
Hello,

I have been trying to resolve an issue for quite some time now. After numerous hours of research I have been unable to resolve my issue.

My main problem: My iPhone 3GS is currently running IOS 4.1 and I am trying to upgrade it to something more recent.

A rundown of what I’ve done so far:

My phone was originally on IOS 6.1 and I wanted to jailbreak and unlock it to use with another carrier. I successfully jailbroke it using a program called evasi0n, at least I think it was jailbroken. I then wanted to unlock it using ultrasn0w. However, I learned that my baseband version was not compatible. I then began to search the internet for a solution to this. The only solution I was able to find that worked for me was to downgrade my IOS to 4.1. I successfully did that, I’m not sure if it was the right decision, but it worked anyway. While on 4.1, my baseband was still not a compatible version. So I then changed my baseband to an iPad baseband using a tutorial I found.

My phone successfully reverted to an ipad baseband. I believe I then used redsn0w to change the ipad baseband to 05.13.04, which was compatible with the unlock with ultrasn0w. I then jailbroke my 3GS while still running 4.1 IOS and unlocked it using ultrasn0w. Everything went fine. The phone was jailbroken and unlocked and my SIM card successfully worked.

I then tried dozens of times to upgrade to a more recent IOS with no luck. I was fine with using the phone on the old operating system, but then a new problem presented itself. Anytime I disconnect the phone from my laptop, when the phone idles, I can not turn it back on. I assume it is on a tethered jailbreak because I was able to turn it on using the “just boot” option in redsn0w, but when I disconnect it, the same thing happens, and it tells me the phone is in DFU mode if I reconnect it.

I was fine with using it while connected to the laptop for the time being. But, I recently changed out the digitizer on the phone and when I first did, I was getting a white screen when turning the phone on. So, I reconnected the cables in the phone to secure them firmly, but the phone was still white screened. The only way I could fix this was to do a hard reset of the phone. But, now that the phone is jailbroken and in DFU mode I cannot restart it using this method. So I assume I moved the screen the wrong way and it now requires a restart.

And with my problem of upgrading IOS, I have tried using sn0wbreeze to create custom IPSW’s. I have tried this for numerous operating systems such as 6.1, 6.0.1, 5.0, 5.1.1, and I have also tried restoring with the stock apple firmware in both itunes 10 and 11. I am currently using itunes 10, however.

Anytime I attempt to upgrade I get a 3194 error. I have searched the internet for this problem and found sites telling me to edit my host file. I am using Windows 7. I’ve tried every variation of host file edits that I could find and usually always get a 3194 error. Sometimes I’ve gotten a 1600 error or an 11 error. I have also tried upgrading while running the servers on tinyumbrella, I’m not sure if that makes any difference though.

I apologize for the very long post, but I thought I’d detail everything I’ve done so far. I’ve probably done a lot more than mentioned above, but that’s a rundown of the basics that I can remember.

So basically I am trying to upgrade my iphone 3GS to a higher operating system than 4.1, while preserving the baseband so I can unlock it. And I am trying to fix my white screen issue.

Thank you for any assistance.

And one final note, I don’t have any of these SHSH blobs saved, that I know of.
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
Too many procedures, should just make a TL;DR. Start fresh.

Download the iOS 6.1 IPSW for the iPhone 3GS and restore with iTunes using that IPSW.

Error fixes:
  • 3194: Host issue. Delete any gs.apple.com lines from your host file. Delete the host.umbrella file in the same directory if applicable
  • 160X: Driver issue. Unplug your device, and uninstall the USB port drivers for all of them. Reboot your PC and retry. If that doesn't work, re-install iTunes 11 (needed for iOS 6 and above). If that doesn't work once again, you'll need to use another computer to do this
Once you're restored, your baseband will be the latest for the iPhone 3GS, which is 05.16.08. Now since I glimpsed at the part where you said you got the iPad Baseband on it, I'm assuming you have the old bootrom on your 3GS. If it's an old bootrom, you can use RedSn0w to jailbreak and flash the iPad Baseband together by ticking both 'Install Cydia' and 'Flash/Install iPad Baseband'. Once you're jailbroken, install UltraSn0w to keep your device from locking up and asking for activation. Once it's installed, downgrade your baseband if you wish, then install UltraSn0w Fixer for iOS 6.1.

Boom. 3GS. Jailbroken. Unlocked. Downgrading your iOS is not the equivalent of downgrading your baseband. They're completely separate.
 
Top