Trouble activating Sprint iPhone 4s on Sprint

Discussion in 'Sprint' started by Andy Somnifac, Jul 14, 2014.

  1. Andy Somnifac

    Andy Somnifac New Member

    Jul 14, 2014
    Likes Received:
    Trophy Points:
    I'm running into some problems activating an iPhone 4s on Sprint, after it had been on FreedomPop for a couple of months. First, some background:

    I have an iPhone 4s, purchased from Sprint, that was on my account for a little over 2 years before it was upgraded. Once upgraded, it sat in a drawer for a couple on months until a friend needed a new phone. About that time FreedomPop (a Sprint MVNO) allowed certain Sprint devices to be activated on their network, no Jailbreaking or unlocking required, just give them the ESN and if it were a supported device, they'd activate it. The iPhone 4S was on the list, so we gave it a try. It lasted maybe 2 billing cycles on FreedomPop. Last Wednesday service on FreedomPop was cancelled because the actual usability of the service was, well, terrible.

    Now that Sprint allows BYOD w/ no credit check accounts on to be added to a Framily ID, we tried to go that route with the iPhone. We called Wednesday morning to deactivate the FreedomPop account and a couple of hours later tried to activate it on Sprint. No dice. They said that the ESN was coming back as "incompatible." I assumed this might mean that FreedomPop has not actually let the device go, and I may need to wait a business day or 2. No problem. I activated an old LG phone I also had so that my friend at least had a working phone with which to make phone calls and send texts.

    Fast forward to Saturday, I do a full reset on the phone, the "Your phone is not activated" message comes up on the lock screen, the Network shows "Unavailable" in General/About so I assumed this means we are free and clear. I even swapped out the SIM card (obtained from Apple that weekend), just in case. I tried to replace the LG phone with the iPhone on the website. I entered the ESN and it said that it was invalid. I tried again, thinking I'd fat fingered it, and same result. I then tried entering the IMEI, and same result. At this point it said I had tried too many times and it directed me to a chat agent. I explained the situation to the agent and s/he tried to activate it and was unable. S/he directed me to call telesales, where I spent 35+ minutes on the line with an agent who was also unable to activate the phone. He made notes and was supposed to escalate to another group for research, after which he'd give me a call with their findings. He said I should hear from him by yesterday, but I didn't.

    So, ultimately, has anyone ever seen anything like this? I need to stress that the phone is NOT unlocked, NOT Jailbroken, NOT hacked in ANY WAY. It is 100% completely stock, purchased from a Sprint store.

    Anyone have any ideas on what could be wrong, and how this could be remedied?

Share This Page