What's new

Stuck on black screen after enter in DFU mode attempt


New Member
Mar 15, 2012
Reaction score
Hello and thanks in advance for your help.

Something weird happened to my iPhone 4. I was trying to enter into DFU mode so I could jailbreak using redsn0w. After having turned it off, I held down the sleep/wake button together with the home button for ten seconds, then held down the home button for another ten seconds, screen went black and I assumed it was in DFU mode so I proceeded to use redsn0w. It didn't recognize it.
This is a list so far of what I have tried to do to restart the iPhone.
  • I unplugged the phone from my PC, it didn't start, as automatically did the couple of times I had gone DFU.
  • I held down the sleep/wake button for five seconds, as to turn it on, it didn't start.
  • I held down the sleep/wake button together with the home button, it didn't hard restart.
  • I opened iTunes and plugged back the iPhone, it didn't recognize it. Not even Windows 7 recognizes it, nor does XP, as I tried in another computer.
  • Even though iTunes didn't recognize the iPhone, I held down again the two buttons to see if it would be recognized, it didn't happen, having iTunes running.
It's really weird, because I don't know what could've gone wrong as i have gone dfu before. Only difference today is that i first did the go-dfu-mode procedure, and then plugged it into the computer. Before, I used to go DFU as stated before the jailbreak/install cydia option in redsn0w.

I bought this phone through Amazon market in America, but I live currently in Venezuela, so Apple service isn't an option. It worked perfectly before, only thing is that it's still locked to at&t due to the whole 04.11.08 story. I also had problems to jailbreak it, but this guy from Ireland told me he had also bught such an at&t iPhone 4, and though he couldn't unlock it, he could jailbreak it, so I figured I'd give another shot.

I'll truly thank anyone's help. I have not the smallest clue what's wrong now with this one. I also searched around here and google and saw nothing about this.

Regards and again, thanks in advance.
Last edited: