What's new

Replaced iphone 5s battery phone works but wont charge


New Member
Jan 6, 2015
Reaction score
Hi guys ,I am new here so please go easy on me. I have poked around many forums looking for a solution before deciding to post here. I just have not had any luck fixing this. Any help is greatly appreciated.

I am going to do my best to clearly explain what has happened with my Iphone 5s. I noticed my battery was losing charge much quicker then normal so i went ahead and ordered a new battery from Ifixit. I consider myself pretty decent at hands on jobs so i went ahead and replaced the battery myself to try and save some money. The installation went as smooth as can be, No broken parts to my knowledge and the phone went back together no problem. I then powered the phone on , it came on just like normal and everything seemed to be ok , besides the fact the the battery they gave me was only charged 13%. This is when my problems started to happen , I grabbed my apple charger and plugged it in like i would do any other time to charge up the battery. I came back in a hour and noticed that it was still stuck on the same 13% and had not moved at all. It recognized the charger and even said it was charging and showed the lightning bolt but would not take the charge.

I started looking up things online about how to fix this and found a lot of people with similar problems after they changed there battery or lcd screen. I then unplugged it and thought maybe it needed to be calibrated so i let it run completely out of juice until the phone shut off completely. Plugged it in again and now it was stuck at the screen when your phone is dead and shows that it needed to be plugged in. I tried cleaning out the the charger port and that did not help. I then thought it might be the battery IFIXIT sent me so i took the phone apart again , and put my old battery back into the phone , put it all back together and it turned on no problem, I thought my issue was fixed but i was wrong. I went a plugged it in to charge it and the same thing happened again , would not take a charge just stayed stuck on the same percentage. I went through the phone and made sure all my connections were good and nothing was broken. The phone has been barley used over the last year and before i replaced the battery it had no problems what so ever and the charger port always worked fine.

Does anyone have any idea what my problem could be? I have read so many forums and spent hours trying to get to the bottom of this with no luck yet. Alot of other people seem to have this same problem happen when they replaced there battery or LCD but cant find a solution. I contacted IFIXIT and they thought it could be a bad battery and are sending me out a new one next day shipping. That was before i tested my old battery and found out it has nothing to do with a bad battery it just wont take a charge now. Any help will be greatly appreciated i no longer have apple-care so that's not a option. i was told to maybe clean all the connections with alchol but im a bit nervous that could cause more problems?

Thank you!


Staff member
Sep 24, 2012
Reaction score
Regina, Canada
Since the old battery won't charge either, it's possible that the charging circuit may have been damaged during the battery replacement.

Most reactions

Latest posts