What's new

Ipod touch x 2 for christmas presents for kids.

Status
Not open for further replies.

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
Hi I have jailbroken 3 iphones in my house all adults which I done myself.

Can the Ipod touch be jailbroken and if so what is the highest Ios it can be done on please.

Thx.

Al.
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
31,340
Reaction score
36,452
Location
Regina, Canada
Hi I have jailbroken 3 iphones in my house all adults which I done myself. Can the Ipod touch be jailbroken and if so what is the highest Ios it can be done on please. Thx. Al.
Which generation of iPod touch do you have?
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
Somt know what ones 2 get yet will be 2nd hand from CEX is there certain models that cannot be JB ? Prob be 2nd/3rd generation what so you recommend bud ?
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
31,340
Reaction score
36,452
Location
Regina, Canada
There is no jailbreak for iOS versions above iOS 6.1.2. You'll either have to get iPods with iOS 6.1.2 or lower or wait for a jailbreak for whatever iOS version is on them at the time.
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
So it dosent matter what generation I get then at all just the ios 6 being the main part dor JB ?
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
As long as the device is below iOS 6.1.3, you can untethered jailbreak the majority of the iOS


Sent from my iPad Mini via Tapa
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
Do even the old ipod touch update to ios7 or does it only update to certain ios on older devices, this would be hmdy to know i.e 2nd generation only updates to 4.3.3 , 3rd generation only updates to 6.1.3 or do they all from generation 1 update to ios7 ?

Thank you so much for your help been great. Just this final question now.

Kind regards.

Al.
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
31,340
Reaction score
36,452
Location
Regina, Canada
Do even the old ipod touch update to ios7 or does it only update to certain ios on older devices, this would be hmdy to know i.e 2nd generation only updates to 4.3.3 , 3rd generation only updates to 6.1.3 or do they all from generation 1 update to ios7 ? Thank you so much for your help been great. Just this final question now. Kind regards. Al.
The only iPod that can be updated to iOS 7 is the 5th generation iPod touch. The 4th generation iPod touch can only be updated to iOS 6.1.5.
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
What about 2nd and 3rd generation please.
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
31,340
Reaction score
36,452
Location
Regina, Canada
The latest iOS versions for iPods are:

iPod touch 1st generation.
iOS 3.1.3

iPod touch 2nd generation.
iOS 4.2.1

iPod touch 3rd generation.
iOS 5.1.1
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
So basically if i buy 2 2nd hand 3rd generationthe highest ios it will be on will be 5.1.1 and it cannot update any higher snd 5.1.1 is JB with what tool ?
 

willerz2

Super Moderator
Staff member
Joined
Aug 15, 2012
Messages
7,663
Reaction score
655
Location
New York
5.1.1 can be jailbroken using Absinthe 2.0.4, RedSn0w 0.9.14+, or Sn0wBreeze.
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
Nice 1 will be buying will let you know if need anymote help, used ansinthe easy
 
OP
J

jockmcd

Member
Joined
Aug 23, 2011
Messages
333
Reaction score
1
So just out of curiousity if i bought the 2nd/3rd gen and updated to the latest ios it woudnt goto ios 7 anyway ?
 

scifan57

Administrator
Staff member
Joined
Sep 24, 2012
Messages
31,340
Reaction score
36,452
Location
Regina, Canada
So just out of curiousity if i bought the 2nd/3rd gen and updated to the latest ios it woudnt goto ios 7 anyway ?
No, you can only update the iOS to the highest version the device will support. See my previous post.
 
Status
Not open for further replies.
Top