What's new

IPhone 4s restore help?


New Member
Jun 4, 2012
Reaction score
I recently purchased an Iphone 4s from Ebay with the knowledge that it was stuck in a boot loop and would hold charge.
I'm, having problems restoring the phone to the factory settings it must have been jail broken before and I'm not sure what
firmware its running tried the shift restore on ITunes with the latest firmware but i get error 21.

Any suggestions of how I can restore the phone???

P.s tried re-jail breaking with absenthe, redsn0w etc but it doesn't work and tried in DFU mode.....
Download a fresh iPSW for your device model here: http://theiphonewiki.com/wiki/index.php?title=firmware

Make sure that iTunes is the latest version.

Enter DFU mode and as you did before...shift+restore to the iPSW.

Sometimes all you have to do is download a fresh iPSW of the proper type and it will work.

Hopefully that helps.
Tried that but it didn't work... any more suggestions??
I think it has something to do with the phone making the disconnecting sound and then reconnecting a few times during the restore, then
it puts its self into restore mode and then I get error 21???