What's new

iOS 5 upgrade broke sound on my 3GS

JonBOY26

New Member
Joined
Sep 18, 2011
Messages
3
Reaction score
0
I have an 8GB 3GS that I use as a backup phone. It has been running perfectly fine, at least until yesterday when I upgraded it to iOS 5.0.1. With the update to iOS 5 came a whole bunch of sound problems.
The following features are not working correctly since the update:
-no unlock sound (setting is active)
-no lock sound (setting is active)
-ringer volume cannot be increased/decreased with side volume buttons
-no sound when playing youtube clips or any other videos
-no keypad clicks
When I receive a call on the phone it rings as normal, and during calls the speakerphone setting plays aloud as normal, so the speaker itself appears to be fine.

Putting the phone on silent causes the phone to vibrate as normal. Switching it off silent causes the current ringer volume setting to be displayed as normal, however any attempts to change the ringer volume with the volume keys cause the logo below to be displayed:
$IMG_0001.jpg
Interestingly I've discovered that if the phone has been left sitting unused for a while when I pick it up and unlock it the unlock sound always works. At that point I can also adjust the ringer volume with the volume buttons but only for a about 3 seconds. After 3 seconds or so the volume buttons stop working, and pressing them causes the above logo to be displayed

Once the volume buttons stop working, if I lock the phone there is no lock sound. If I then immediately unlock it there is no unlock sound either, and the side volume buttons don't work. So the only time the sound behaves as normal is if the phone has been left unused for a while. 3 seconds after I start using it the sound and volume button functions drop out.

It's as if a component of iOS is launching in the background and causing a conflict with the effected sound functions.


I've tried restoring the phone but that didn't help. I tried putting the phone into recovery mode and then restoring from there but that didn't help. I've tried restoring on PC's and on Mac's but hasn't made a difference. I've tried restoring from backups as well as setting up as a new phone.
I've seen a couple of other people on various forums with the similar issues whereby upgrading to iOS 5 broke their volume and mute buttons on the 3GS as well as the iPad, however I'm yet to find anyone that has been able to fix the issue.

Any suggestions would be greatly appreciated.
Thanks
 
Last edited:
OP
J

JonBOY26

New Member
Joined
Sep 18, 2011
Messages
3
Reaction score
0
well I just attempted a restore from DFU mode (screen was completely black when iTunes detected a phone in recovery mode) but that didn't help at all.
 

Most reactions

Latest posts

Top