What's new

Downgrade 5.1 to 5.0.1?

threatmatic

New Member
Joined
May 10, 2012
Messages
4
Reaction score
1
I have a 5.0.1 iPhone 4S and it's jailbroken. However I have a hardware problem with this phone so Verizon is sending me a new one. Problem is that the phone I'm getting is a 5.1 (I groaned when he said that.)

I have been jailbreaking with the iPod Touch for a long time so I'm new to iPhone jailbreaking. I never even heard of SHSH blobs o_O.

So there is no possible way to downgrade from 5.1 to 5.0.1/5.0 without these blobs? Or use my blobs from my jailbroken phone now and put it on my new 5.1 phone?
 

Skull One

Super Moderator
Staff member
Joined
Apr 27, 2011
Messages
4,431
Reaction score
580
Location
Earth
From what I have studied on the subject matter, the phone's unique internal ID is used as part of the signing process. So I doubt you can use your blobs from one iPhone on another.

Hopefully one of the more knowledgeable jailbreakers can chime in for sure tonight.
 

Jmills87

Well-Known Member
Joined
Jul 28, 2011
Messages
3,644
Reaction score
163
Location
The Land of Ice and Snow
So there is no possible way to downgrade from 5.1 to 5.0.1/5.0 without these blobs? Or use my blobs from my jailbroken phone now and put it on my new 5.1 phone?

No, there is no way to downgrade without SHSH blobs, and no, you cannot use blobs from another device to downgrade.
 
OP
T

threatmatic

New Member
Joined
May 10, 2012
Messages
4
Reaction score
1
Thank you for the information! I just got my iPhone in the mail and it said on the outer packaging of the phone it was ios 5.1. But when I activated my phone it was still at 5.0.1 so I jailbroke it !!!! So I'm happy and I'm backing up my blobs now.
Thank you again :)
 

Jmills87

Well-Known Member
Joined
Jul 28, 2011
Messages
3,644
Reaction score
163
Location
The Land of Ice and Snow
Thank you for the information! I just got my iPhone in the mail and it said on the outer packaging of the phone it was ios 5.1. But when I activated my phone it was still at 5.0.1 so I jailbroke it !!!! So I'm happy and I'm backing up my blobs now.
Thank you again :)

That's great! Unfortunately there's no way to save your blobs though. Once Apple has stopped signing the firmware, you can no longer save them. With older A4 and lower devices you can dump them with iFaith(assuming you are currently on the firmware you want the SHSH for), but that will not work on a 4S. Just make sure not to mess anything up so you dont have to restore until the 5.1/5.1.1 untethered jailbreak is released.
 
OP
T

threatmatic

New Member
Joined
May 10, 2012
Messages
4
Reaction score
1
I dunno, I just went into TinyUmbrella and it allowed me to save my blobs for 5.0.1 with no trouble. I believe you can use the latest redsn0w to downgrade using those blobs only if you upgraded to 5.1 by mistake?
 

Jmills87

Well-Known Member
Joined
Jul 28, 2011
Messages
3,644
Reaction score
163
Location
The Land of Ice and Snow
I dunno, I just went into TinyUmbrella and it allowed me to save my blobs for 5.0.1 with no trouble. I believe you can use the latest redsn0w to downgrade using those blobs only if you upgraded to 5.1 by mistake?

That means that you already had them saved through Cydia and TinyUmbrella just pulled them from there. And yes, you can downgrade from 5.1.1 to 5.0.1 using blobs and the latest Redsn0w(until Apple patches it).
 

chadx9

New Member
Joined
Jan 25, 2012
Messages
57
Reaction score
0
Alright I was just wondering if ican get any help here I did have my iPhone jailbroken in 5.1 but updated about 2months ago I do not know if it saved my blobs or whatever so I download tiny umbrella and started the TSS server and it's taking forever and honestly I don't know what im doing to downgrade to 5.1 to re jb my iPhone 4s again any help? Please and thanks.
 

chadx9

New Member
Joined
Jan 25, 2012
Messages
57
Reaction score
0
And how do I get my blobs from tiny umbrella?
 

chadx9

New Member
Joined
Jan 25, 2012
Messages
57
Reaction score
0
I did it and It says Cydia has it saved what do I do now?
 

DaMrsz31

New Member
Joined
Nov 15, 2011
Messages
44
Reaction score
0
$image-2936976007.jpg

This is what it tell me when I try to use the restore with Ipsw
 

zig9449

New Member
Joined
Aug 20, 2011
Messages
3,206
Reaction score
108
Location
PA
DaMrsz31 said:
<img src="http://www.iphoneforums.net/forum/attachment.php?attachmentid=6670"/>

This is what it tell me when I try to use the restore with Ipsw

The iPSW may not fully be downloaded or you downloaded it from Internet Explorer. Never download an iPSW from Internet Explorer. They just don't work.

Delete the iPSW you were using and download again through Firefox or Google Chrome.
 

Jmills87

Well-Known Member
Joined
Jul 28, 2011
Messages
3,644
Reaction score
163
Location
The Land of Ice and Snow
It depends on your internet spped. I can download a 4S IPSW in about 13 minutes. And yes, that error indicates that the firmware file you were using was corrupt.
 
Top