What's new

Disappeared apps in share

itelephone

Active Member
Joined
Apr 2, 2021
Messages
132
Reaction score
95
I didn’t do anything special but today almost all apps are missing in the share sheet, including most Apple apps. They are not available in More-Edit-Suggestions either.
I tried:
close all apps and reboot;
offload some of the many missing apps, reboot and reinstall;
reset all iPhone settings and reboot;
change system language and reboot.


It’s iOS 16.6 and iPhone SE 2nd gen.


IMG_2031.jpeg
 
Last edited:
I chatted with Apple Support and they escalated my case to a Senior Advisor. He tried other tricks such as Forced Restart, a reset of privacy settings, toggling Siri settings, toggling notification settings, deleting the recently installed apps, Screen Time, VPN’s, and whatnot. About an hour on the phone and shared screen, but nothing worked so far. Btw, Save to Files is missing too, in the Share menu (from any app I tried).
Eventually the Advisor said he had tried everything, and probably the issue is due to the high number of apps installed on my phone (not the size, as there is still 45GB available, but the sheer number: 468) and suggested I remove some. If even that doesn’t work, I’ll have to erase the phone content after a backup and reinstall iOS from scratch.
 
Last edited:
Deleting a bunch of apps did not do the trick, so I think I am going to erase and restore from the automatic iCloud+ backups.

p.s. I now realize I should have started this thread in iPhone Help. Moderators please move my thread if that’s the case, thank you!
 
Last edited:
Thanks Mods for moving this thread to the right place.

As to the iCloud+ Backups, I hoped for multiple backups (since there‘s plenty of space) but it looks like there is just one, and its date and time is yesterday *after* the share sheet got corrupted. So I don’t know if restoring would help. Hmm… Any advice?
 
The Apple Advisor mentioned that it could be a case of corrupted Share Sheet. Or was it "confused" with too many applications, or maybe a specific application made a mess? Who knows! As I said, all the known fixes didn't work in my case. There is a thread about this kind of bug on the Apple official forums. Looks like some users could fix it for good, others fixed it but it came back, some others could not fix it at all.
I am no iOS expert, but thinking about it I guess the Share Sheet must be sort of a configuration file created by the operating system at iOS installation and updated every time new apps are added. Or something like that.
Therefore, my bet is the file will be recreated-if I reinstall iOS, regardless of the restored backup, I mean even if the backup is not prior to the corruption.
Also, I hope that the same trick would work by reinstalling iOS over itself (I think it can't be done in iTunes for Windows but it's possible via 3rd party sw like iMazing), thus not having to erase the data on the phone before re-installation.
But, that's just my theory.
 
Looks like I fixed it. I had to resort to the final weapon — erase iPhone and restore from an iCloud backup. Before that I tried an iOS 16.6 reinstall over itself (no data erase) via iMazing but that didn’t fix Share.
Interestingly there were 2 iCloud backups, not just the Last Backup that I could see in Settings-Apple Id-iCloud-Manage Storage-Backups-device, so I could restore a backup prior to the bug.
I still wonder if reinstalling iOS from scratch and restoring a newer backup would have fixed it anyway.
 
Last edited:
I spoke too early. The Share Sheet broke again. For instance no Save to Files in the share menu. Only very limited sharing in photos (as in the screenshot in my first post) and Safari. No sharing to WhatsApp in PDFs. But I can share a jpg file to WA from the Files app!
This is not good. Sharing is a core feature.
I am afraid I can’t fix it even if I move my profile to another iPhone. (???)
 
Eventually it looks like it fixed itself, I don't know why or how. Let’s hope it will stay that way .
I was getting ready to reinstall from scratch application by application.

Not a good experience, Apple.
From what I read and from what Support said, I gather it’s kinda known bug.
 
Top