My texts show up as being sent from my email

Discussion in 'iPhone Help' started by dvoso, Jan 22, 2012.

  1. dvoso

    dvoso New Member

    Joined:
    Jan 22, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    When I text people it shows up as being sent from my email. Does anyone know how to fix this?
     
  2. tintbob

    tintbob New Member

    Joined:
    Nov 29, 2011
    Messages:
    209
    Likes Received:
    7
    Trophy Points:
    0
    If you do a search on this it has been covered before, sorry but I couldn't copy and paste the answer
     
  3. beccadely

    beccadely New Member

    Joined:
    Feb 20, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    The same thing happened to me when receiving a new Iphone. It is super stressful because anyone who was sending you texts to your phone number... you never got them. Anyway here is the solution:::


    Settings>Messages>Receive at>Click your apple ID (the email address) > Change Location.

    For some reason I wasn't receiving my texts at my phone number because United States was not selected as a location. After this, if I remember correctly you need to select your phone number as the receiving address. If that doesn't fix your problem log out of your apple ID and log back in. Hope this helps!
     

Share This Page



Search tags for this page
iphone sending texts from email
,
iphone sending texts from email address
,
iphone texts from email
,
my iphone is sending texts from my email
,
why are my texts being sent from my email
,
why do my texts show up as email
,
why does my email show up when i text
,
why does my email show up when i text from my iphone
,
why is my email showing up when i text
,

why is my iphone sending texts from my email