To register for an account, click here...
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    2
    Member #
    18152

    iphone 4 battery starts to drain fast when no internet

    The problems with my phone start when the phone has had got an internet access for a few days. I noticed these problems while on longer business trips where i dont want to you roaming. The phone starts to eat the battery really quicky, even when all extra software and location services are off. The battery is dead with-in 9 hours of recharging, where as normally when 3g is off it lasts for many days. The first time the phone was 'miraclously' repaired when i returned home and the phone was allowed to use 3G. On a following trip the phone started to act similarly and burnt 20% of battery in roughly 2h. I had a hunch that maybe it could be about the internet connection, and shared wlan with my macbook pro to test this theory. Supprisingly after that the battery consumption became normal and phone is working okay.

    Does anybody have a idea what could cause this? I noticed that some people have had similar problems when they have ran out of data subscriptions.
    Last edited by Samtheman; 05-14-2011 at 01:40 AM.



  2. #2
    Junior Member
    Join Date
    Apr 2011
    Posts
    8
    Member #
    16781
    Hi, friend, I have the similar problem when I first time using iPhone in another country. The battery can last only 6 hours or less. To that extend I have to buy another supplementary battery. I was advised to turn off app such as stopes location service, off 3G, off push notice, off push mail, off wifi, off Bluetooth, off EQ, off data roaming, adjust brightness, off cellular data. In spite of all these action taken, the phone still suck. It was until recently a friend told me to off all the above, AND MAKE OF SOFT RESET. Since then the problem solved. Now whenever I am in overseas I turn off all except the normal telephone. By end of the day I still have about 60% of battery.

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    2
    Member #
    18152
    Well no problems currently (abroad). After wifi connection was made, no problems. Its weird that the problems start after 4-5 days when the phone has not been connected to internet. It took approx. this amount of time for problems begin during my last trip. Once the phone is connected for a few minutes the problem goes away.

    A believer in conspiracy stories could probably claim that the phone sends something to Jobbs every now and then....

  4. #4
    Junior Member
    Join Date
    Dec 2011
    Posts
    4
    Member #
    50942
    I've experienced the same problem, a friend told me it was due to my holidays in a very cold wheather area, with snow and a temp below 0.c ,
    very cold temperatures can reduce life of a battery (same for a car), and to change my battery with a high tech lithium one.

  5. #5
    Junior Member
    Join Date
    Oct 2011
    Location
    Carrollton, TX
    Posts
    13
    Member #
    39264
    Try putting your phone in "Airplane" mode when travelling. It prevents battery drain by not having to constantly search for connections etc.

    Good luck.

    MrBill

  6. #6
    Junior Member
    Join Date
    Dec 2011
    Posts
    5
    Member #
    52189
    Quote Originally Posted by Samtheman View Post
    Well no problems currently (abroad). After wifi connection was made, no problems. Its weird that the problems start after 4-5 days when the phone has not been connected to internet. It took approx. this amount of time for problems begin during my last trip. Once the phone is connected for a few minutes the problem goes away.

    A believer in conspiracy stories could probably claim that the phone sends something to Jobbs every now and then....
    Have you turned off auto send diags & usage? Settings>General>About>Diagnostics & Usage>Don't Send.

    Cheers,
    kev


Home | Forum | Active Topics | What's New

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. My app thumbnails have gone weird
    By jd90 in forum iPhone 3G
    Replies: 3
    Last Post: 03-26-2011, 10:59 AM
  2. Battery problem?
    By jscollin in forum iPhone Help
    Replies: 3
    Last Post: 03-02-2011, 06:31 PM
  3. 4.2.1 tethered 0.9.7b6 - weird
    By craigfoot in forum iPhone Jailbreaking
    Replies: 2
    Last Post: 01-18-2011, 04:59 AM
  4. weird SMS response
    By sakumaxp in forum iPhone Jailbreaking
    Replies: 2
    Last Post: 12-29-2010, 02:44 PM
  5. my cydia is weird....
    By umarrehman187 in forum iPhone Jailbreaking
    Replies: 7
    Last Post: 10-17-2010, 02:26 PM

Search tags for this page

battery on iphone 4 dies quickly

,
iphone 4 battery dies fast
,
iphone 4 problems 2011
,
iphone battery died cold
,
iphone battery dies in cold
,
iphone battery dies when cold
,
iphone died in cold
,
iphone dies in cold
,
iphone dies when cold
,
my iphone battery dies when its cold
Click on a term to search for related topics.

Tags for this Thread